Speaker Companion - be quiet for a while(Turn off notifications temporarily)?


#1

I’m using the speaker companion to create a voice notification with door/window/motion sensors. My favorite feature.

I’ve been looking for this feature since I first got into Smartthings. I had kept my Honeywell alarm in place to simply play “beep beep beep, the front door opened” and similar sounds for other doors and windows. With the Sonos wifi speaker I can do this and more, love it. I run this notification all the time. It would be nice to have a quick, don’t notify me for a while" selection. With Alexa integration, would be nice to “Alexa, tell smarthings, don’t notify for xx minutes”


#2

What are you using for your notifications from ST? I have done exactly what you are talking about. I have a switch (semi-virtual…it’s a ST_anything single LED indicator light) called Audio Alerts. If this switch is off, none of my notifications occur and if it’s on they do. I can turn this switch on or off from Alexa or from other automations. For example, if i’m going to bed, i turn the switch off so no notifications happen when I’m asleep. The only caveat to this is that all my notifications also originate from WebCore. It’s the only place i’ve found that allows me to place a restriction on only notifying me when the switch is on. I’m sure there are other methods you could use with Virtual Switches/routines/location mode but I didn’t want to get that complicated with them. If you’re already using WebCore, then it should be fairly easy to set up your notifications there.


#3

They have it hidden - I really think Samsung has no idea what they’re doing with this sometimes. Go to SmartApps, Music & Sounds, Speaker Companion. Select Play a notification.


#4

Wait…what? Are you asking how to get a notification to play or how to get it to not play sometimes?


#5

You asked what I was using for notifications.


#6

Yes, but that doesn’t do what you want it to do. LMAO.


#7

I do have what I want, I just want to silence my notifications, it would be cool if I could do this with an Echo.

Your comment was not responding to my question, it appears your stating what you can and can’t do with an echo.

What I’m looking for isn’t control over a switch, I want audible notifications when a sensor is tripped. (Echos do nothing for this at least so far)

I have sonos, working with speaker companion, that does what I want to do. I have it set with doors, windows, locks and motion. This works great! My thread is stating that I would like to be able and silence this quickly, easily.


#8

What I am saying is that in order to get what you want you will have to do something different. You won’t be able to just add on something to do what you want. What i described is how I accomplish what you asked. I use a virtual switch, that when enabled, allows notifications and when off blocks them.


(Stella Johannes) #9

I know exactly what @the_stranger is talking about because I have this same set up. I think @ryan780 is either smoking something or lost LOL!. All you have to do is send a mute command to your sonos. I use a timer in sharptools to unmute it after 8 hours. You could use one of the other rule engines or just turn it back on manually.


#10

That will only mute that speaker. If your notification has a volume level set command it will unmute the speaker. Plus, if you are using the speaker for something else then you will hear the notification.
Do you know what webcore is? If not, then never mind. But I have done exactly what the OP asked for using that. If you want details, say so. If not, then good luck.


(Stella Johannes) #11

Well this works for me just fine… As @the_stranger said, you’re not even answering his question! LMAO


#12

LMAO… How am I not? The OP asked if there was a way to silence alerts via Alexa. That is the easiest way to do it. If you don’t want to know, fine, don’t listen.
I didn’t specifically say that you can turn a virtual switch on and off via Alexa but I assumed you knew that. Sorry for not dumbing it down to a level you could understand.

And @the_stranger, if you want to change something, then you don’t have what you want do you? You want to use speaker companion and silence your alerts via Alexa. That, to my knowledge, isn’t possible. However, using notifications from WebCore allows you to add a restriction around the piston that does the notification. That restriction can be a virtual switch that you can turn on and off via Alexa. This is the method that I am using. I can ask Alexa (or Google) to turn off a virtual switch called “Audio Alerts”. When this switch is off, no alerts play. You could set it up the other way. Have a switch called mute and when it’s on your alerts don’t play. I don’t believe that muting your speaker is the best option but if that works for you, good for you. I am merely trying to point out another way of doing it. And don’t say that it doesn’t work because that;s what I’m using. And don’t say that it’s not answering the OP’s question, just because you don’t understand it.


#13

For having joined the forum 2 hours ago, you’re awfully rude. Maybe read a little more and post a little less.


(Alan Lambert) #14

Add a Virtual Switch called “Notifications”.
In your piston that creates the chimes add a rule to not run when “notifications” is off
Say “Alexa turn off notifications”


#15

Thanks Ryan and Alan for the help. Ryan, I think you provided more information than I knew what to do with - I no nothing about webcore, so you lost me with that reference.

Stella, I installed BigTalker2, it’s a little complicated on the install but does much more of what I need. I can select individual wifi speakers for each notification.

On the virtual switch. I added a virtual switch, Big Talker has a setting to disable when a virtual switch is turned off.

Thanks!!