Smartthings can't find sonos


(Joe Asmar) #1

Hi Folks

I just purchased a Sonos One , play 3 sub and playbar. while all equipment works perfectly none seem to be found by smartthings . So far I have tried :

1- Static IP
2- Reboots of all equipment
3- Tried to find through add things and marketplace
4- Waited 30 min for the find to complete multiple times

Note that I can through Alexa get to smartthings so turn on lights etc… but smartthings app can’t seem to find sonos so unable to automate any trigger based process

Can anyone help up here. it’s a real bummer .


(jkp) #2

Reboot of your router as well?


(jkp) #3

(Joe Asmar) #5

Looked into the above thread JKP and executed all recommendations … no success


(Joe Asmar) #6

any other hints that can help ?


(Joe Asmar) #7

It cant be that I’m the only one facing this problem ! I just upgraded the routers firmware factory reset it and tried … same old problem … No sonos on the horizon

Please help


(Joe Asmar) #8

Bumping this up… Sonos still undetectable… Anyway I can trace this thing, when I look at the logs it’s not even seeing the hardware


(Joe Asmar) #9

really need your help here. can’t figure it out… is there anything I should do on the speakers. my smartthings can’t find them . pretty much impossible .


(Michael) #10

How do you have the Sonos connected to the network? Via a bridge, hard wire, or via WiFi? All of this works via broadcast and/or multicast announcements. If anything in the network is blocking those announcements, it won’t work.


(Joe Asmar) #11

Hi Mike

it’s connected via WiFi and working perfectly . except that smartthings can’t see it …


(Michael) #12

Are you able to control your Sonos from a wired device like a Desktop or Laptop? What WiFi router/AP are you using?


(Joe Asmar) #13

Hi Mike

Yes I can control the sonos via laptop

my router is tp link and I’m using dhcp/ address reservation to reserve their IP

Any hints ??


(Michael) #14

Is the laptop connected to the network via wired or wireless? I am trying to establish if there is challenges with the Sonos broadcast announcements being forwarded properly between your WiFi and wired portions of your network. We need to prove that a wired device can see and manage the Sonos.


(Joe Asmar) #15

Hi Mike

The sonos is discovered by all devices I have wirelessly, Even the lutron hub can see the sonos but smartthings cant’ even when I check the logs of smartthings none of the speakers is appearing on the logs. As if they don’t exist .

I have also connected on the the sonos speakers wired to the router, still negative results,


(Frosty) #16

I am also having this problem - my sonos one’s are not seen by smartthings - both on same wifi network…

Looking for help also to get it going

thanks


(David) #17

Not sure if this will help but my Sonos was not discovered by SmartThings for many months. Then, as soon as I added a TP Link WiFi Adapter and Extender plug, the sonos speaker was discovered when ‘adding a Thing’ in SmartThings. I can only conclude that it requires a stronger WiFi signal for SmartThings to detect it…

David.