Sonos Notification volume is way too loud

Hi,
I’ve searched and can’t find an answer. I just setup my Smartthings hub and have notifications setup to play through ceiling speakers connected to Sonos Amps, but the volume is WAY too loud. How can I adjust that? I can’t find anything in the app.

Thanks!

Which app are you using… Classic or the new ST app? What are you using to send the notifications… Routines, automations, SHM in the Classic or STHM in the new app or other? What are you sending notifications for? (Asking in case we can recommend something better)

I think I’m using the new ST app (version 1.6.41-349 on my iPhone. I’m using automations to detect when a door is unlocked and then send notification via the speakers.

Not sure if this will work but you can try it. In your Automation before you send the announcement to the sonos speaker, you can add —> control device, select your Sonos speaker and set the volume. Then have the announcement sent to it. Then add another action to control the Sonos speaker and set the volume back to what you want it.

Just a thought,

1 Like

There is an option in the code when the audioNotification used to set the volume, but somebody has still not included it there. The playTrack has option to define the volume, but it is not included in the Automation builder.

@Brad_ST, @jody.albritton would be possible to include this feature in the next version of the v3 App?

When the notification sent to a Sonos or any audioNotification device, it would not just offer the language and male/female option, but the volume of the announcement.

2 Likes

FAQ: how to tell which version of the SmartThings mobile app that you have

Thanks @jkp but that did not work. It sounds like GSzabados is on to soemthing with the issue. The automation builder needs to allow setting volume levels. This is a real bummer as I’m completely blocked from sending announcements throughout my house. My wife, toddler, and 3 month old won’t tolerate the loud notifications. It freaks the dogs out too.

You can use the BigTalker Sonos mod what I have posted in the other topic.

If you have access to RBoy apps you can also check out this app which lets you control the volume for custom spoken notifications on Sonos:

@Brad_ST @jody.albritton

Can volume adjustments please be included in the next app update?

I’m currently using jishi http Sonos and Microsoft Cognitive services and its working great but if i can simplify TTS with native functionality that would be a plus.

I’ve tried the modified Big Talker that @GSzabados created (thanks!) but it’s at least a 2-4 second delay with the announcement.

Sorry to revive this old thread, but frankly surprised there isn’t more on this issue. I just tried the “read message aloud” action in the new SmartThings apps and am floored at how loud this is with no option to adjust volume. Are there any plans to fix this?

Currently using echospeaks and webcore which has worked reasonably well, one to two second delay, but never in sync with multiple speakers. Now with the notice that I just received about shutting down the current implementation of echospeaks and having to move to the new app I’m figuring out alternate ways to get verbal notifications.

The native SmartThings feature actually works well with zero delay. It also plays multiple speakers in sync. It’s just ungodly loud… I’m using this feature with Sonos speakers.

I’ve tried to just use the routines in the Alexa app to get verbal notifications, but it’s terribly slow. Not sure if this is normal, but it could be 15-30 seconds late.

Any suggestions on getting the native SmartThings automation to fix the volume issue?

2 Likes

I’m also shocked this was never fixed. Smartthings support had told me the issue is on Sonos side but that makes no sense to me. It seems the volume capability needs to be exposed so you can choose the volume level.