SmartThings Community

Sonos Issues


(Ron S) #2

For me everyday there is some issue or the other with Sonos. I don’t get proper notifications but I live with it as its still in the lab. As such that reminds me to open a ticket whereby I have three Sonos but ST thinks I have four. Probably confusing the BOOST as the fourth one. And of course I have ip’s fixed for these Mac addresses to survive reboots of my router.


(Steve) #3

This is the strangest issue I’ve had so far. The only thing the speakers are not doing is playing the custom messages/weather. When the action is triggered, currently playing music pauses and I can see the volume control being set to the percentage I have entered in the app, but it just doesn’t play the audio. I don’t know what else to try.


(Ron S) #4

Go to the labs section. Click on each of the notification that you created and hear it play on the sonos manually. Use the arrow button. Things will be fine for a while thereafter as if it has to be in the play list. Wiid guessing.


(Benjamin Ferguson) #5

My Sonos weather notification quit working about a week ago. I’ve tried uninstalling and reinstalling, even manually triggering the weather forecast does nothing.


(Steve) #6

If I go to the Labs section and rapidly tap the icon to manually trigger the weather/custom sounds it does eventually play. Hopefully it starts working again soon.


(H Guess) #7

Hi,

I talked to a rep. from SmartThings awhile ago. He acknowledged issues with Sonos and basically without going into detail stated that there is something in the works. I was pretty happy to hear that because I love my custom voice notifications when it works properly. I decided for the time being I would disable Sonos and wait to see what happens. I really hope this issue is addressed in version 2.0. I’m really thinking voice interaction is going to take front stage next year as well as integration/improvement with devices such as Amazon Echo, Ubi, and Ivee Sleek etc. It’s going to be a very interesting year.


(Kevin Dunn) #8

I’ve been having similar issues. At least I know I’m not crazy and can at least stop banging my head against the wall.


(Greg Allen) #9

Similar issues here. Mood Music and Weather app stopped working completely. Lots of these in the logs:

groovy.lang.MissingMethodException: No signature of method: physicalgraph.sandbox.CapturingLoggingListener.grace() is applicable for argument types: (java.lang.String) values: [Is neither XML nor JSON]

(Joshvillbrandt) #10

I’ve been having the same issue as @nextrev. Any updates on this from a SmartThings staff member?


(Fernando) #11

Same here, custom message, or dog bark not working when contact open or sensor. Hsa anyone figure a way to fix it?


(Joel) #12

yeah no luck at all for a long time on sonos. i loved the weather update in the morning when we got up. that increased WAF 10 fold but it’s gone now. Smartthings please help you’re our only hope.


(Mike Franks) #13

Same issues here. Works then doesn’t… Can’t fix…
Hoping 2.0 will fix these issues…


(Jason) #14

I reduced my forecast to just “current conditions” and it still works every morning even finishing with my chosen sonos playlist. However, if I try and stack the current condition with “today’s forecast” or even have any other combination of, the forecast and corresponding playlist will not fire. Not sure what the issue is but hope this finding helps.


(Jesse S) #15

I can confirm same sonos issue not playing multiple stacked forecasts (current, daily, tomorrow, etc) and same observation – reducing smart app to one weather forecast works while having multiple does not. I noticed the break in sonos/ST about two weeks ago.


SmartThings Text-To-Speech for Sonos (playText) not working?
(Micheal ) #16

There is an issue that multiple folks have submitted tickets about regarding the TextToSpeech function. @tslagle13 at SmartThings is fully aware of the issue…


(Joe) #17

I just got my hub v2 up with my Sonos and am having a problem with the Sonos Weather. I can play greetings and single word text to speech though.

I found this and wondering if this is still an issue. If so, do we know when it will be fixed? If not, can someone share how they got it working.
Thanks


(Scott Duggan) #18

It’s a known issue, but not a priority right now. Many of us are experiencing the same problem.


(Joe) #19

Thanks for the confirmation!
Will put that on my list of nice to haves to revisit later.


(Ule) #20

Hi just try this

Its working fine, just follow the instructions


(Paul Peters) #21

Hi Everyone,

I have started to run into an issue with my Sonos Play 1. It has been working fine for a few weeks (weather app has never worked). Lately when I get home, the Sonos is no longer responding to the Smartthings hub. It has been happening every day now for the last week and a half. In order to get it working again, I have to unplug the Sonos and the Smartthings hub for about 10 minutes. I plug the hub back in, then plug the Sonos back in, and finally turn the Sonos on using the Sonos app. Once it is playing, I go to Smartthings app and turn the Sonos on/off and now everything is working again. Anyone having the same issue.