Sonos grouped speakers volume problem

I have two Sonos speakers that I have usually grouped. I have setup a playlist to play for the dogs when I leave the house. However, I am having some trouble with the volume control. If I set the volume to 20, I have found that the one speaker will play at 20 and the other speaker just seems to pick its own volume setting like 60 or 80. Just about blasted my dogs out of the house the other day and I didn’t realize until I came home. How do I get each speaker to play at a certain level?

SmartThings is not Sonos “group” friendly. There were statements from SmartThings over a year ago that they were working with Sonos on this among other integration issues. However, I suspect this work is dead since we haven’t seen anything for some time.

So what is the best way to set this up then?

I don’t think you can. Even if you don’t use groups, if you try to send something to two Sonos devices at the same time it can screw things up. Your only choice is to keep it real simple. Most people are successful with only one Sonos 1. However, you might as well get an Amazon Echo instead in this case.

I have 11 Sonos devices in five rooms and have been frustrated that the potentially powerful integration with SmartThings has been neglected.

1 Like

My Scenario:

3 Play1’s and 1 Sonos BOOST

2 of the them are grouped (Family Room). 1 is not (Master Bedroom)

I use the Sonos Connect which discovers 4 Sonos devices.
I ignore the BOOST.
I only select “ONE” of the grouped Sonos Play-1’s in Family Room and the one in Bedroom.

So, basically even though 4 devices were found by Sonos Connect, I chose only two for use in ST.

So do you find that the other Sonos that is grouped plays at the same volume as the one that you have selected?

Yes… 20 characters. Try to select the primary play-1 from the group i.e. the one on which you dragged the second one to create the group in Sonos controller app. Don’t think that should matter though.

Your Family Room Sonos are paired. Pairing seems to work fine, though as you point out you end up with confusing quantities of Sonos Connects.

If you try to group your Family with your Master Bedroom, however, all bets seem off. First off, you have to know which is the “master” because SmartThings only will respond to the master of the group.

This is what I have now. The poring and grouping may be really confusing and it is to me… After not touching the integration for months…

Yes Ron, your Family Room speakers are paired. To “group” your Family Room and Master Bedroom speakers tap a room title bar then tap the “Group” button. From the next screen select the other room or tap “Select All” for party mode. This plays the same thing in all rooms. Unfortunately, control through SmartThings falls apart once you set it up like this. @pcgirl65 pointed out one issue and there are many more.

There is so much potential for this integration. The lack of progress is so depressing.

I stand corrected. And bow my head in embarrassment! :frowning: I have been totally malfunctioning these days! Totally forgot the difference between grouping and pairing.

Please, no head bowing. You’ve helped enlighten me with your posts.

I don’t feel ok these days and you guys keep me going. Heart and pancreatitis chronic doesn’t help! Thanks!

So it looks like Ron S’s way of using pairing with the Sonos but only selecting one of the paired sonos in ST works best. I waited for the ST ver2 to come out and so far since setting it up last week I have discovered that I can’t add my family’s iphones to it yet for presence sensors and Sonos has difficulty. Yikes!

So, even if I just select the one Sonos in Sonos Connect and setup the smartapp to play the one sonos the volume levels for both the sonos are different when they start. The sonos that I setup in the app has the volume level at 25 as per the smartapp but the other sonos that is paired with the first one has a volume level of 45. I have noticed this to be 60 sometimes and 80 sometimes. I wish this could be all at the selected volume.