So frustrated with SmartThings


(Joe) #1

this weekend smartThings has really let me down. I tried to install an app named Nest(connect) from the IDE. It allowed me to publish it, but when trying to install it through the app it says, it says “you are not authorized to perform that requested operation”.

Then I noticed my Fibaro motion sensor lux value isn’t updating and the amount of time it takes from detected motion to turn on a light is all over the place.

Now my presence sensors aren’t triggering my garage door to open in a timely fashion.

This isn’t makeing my feel warm and fuzzy about smartThings. I have been having problems with it for over a week now. Grrrrrrrr


(DLee) #2

Hang in there. Think of it as on ongoing hobby. It does mostly work.


(Joe) #3

I wouldn’t call something not working for over a week “mostly working”. Things were working wonderfully until about Christmas time for me, and then it started going down hill. When your “Hobby” impacts a household, it’s hard to justify it.


(Tony - SmartThings Unpublished Contributor ) #4

Think of it as on ongoing hobby. It does mostly work.

I’ve been unable to add anything for days and had a recurring Hue hub issue for 2 weeks. At this point, I would say that it “mostly doesn’t work” or “is a brick.”


(DLee) #5

Don’t take my first reply the wrong way. I empathize and have shared my frustration with ST directly before. I understand the impact.

Nest and Fibaro are still not fully official officially supported device types IIRC. So you can expect some extra work on those. The Nest error sounds like the device didn’t install. I get that error when I delete a device or smartapp then try to reload the page.

Presence sensors are built to only ping every so often. I think I read 30 seconds or something to save battery life. I never purchased one for this reason and other problems mentioned in the reviews like false departures. There still is no good out of the box solution for presence with instant action. Ben did say in the Hub v2 thread that ST may eventually support BLE bluetooth beacons. That can help with presence if implemented correctly. Ideally it would be your phone detecting a beacon in your garage and opening the door if in away mode. But perhaps with some BLE gateways you could have the beacon in your car and SmartThings would detect your arrival. Until then, there is no easy instant real-time presence detection method built into ST.


(Jody) #6

Check out https://www.smartthings.com/product/works-with-smartthings/

As others have pointed out, you are using a community provided device type. As far as the fibaro goes, if you were using the device type found in the forums, you need to edit the device to use the official device type.

Were your presence senors working better at some point or has this always been the case? Things to check here would be batteries and wireless accessibility.


(Joe) #7

I know I am using a community provided device type. However, now that I have attempted to install this app, I can’t edit or uninstall the app. Every time I try it throws me the error I initially posted.

As for the Fibaro, I am using the one supplied by smartThings. In fact, I didn’t buy them until I saw smartThings supported them.

My presence sensor is my iPhone, but I also have a smartThings presence sensor which has the same problem. All of this was working on and off last week. I did have problems with the outages they notified us about.


(Jody) #8

Have you tried to uninstall the app via the locations section of the ide?

https://graph.api.smartthings.com/location/list

Click the location
Scroll to the bottom and click the list smart apps link
Click the edit link at the top of the page.
Find the smart app you wish to remove and click uninstall.

As for the fibaro motion detector, can you press the button 4 times and after the light turns blue wait a few seconds and press the button again?


(Joe) #9

I can not remove it from there. It says it in use by one or more users.

I’ll have to try the Fibaro suggestion tomorrow.


(Jody) #10

If you have not opened a support ticket with support@smartthings.com, that will likely be the best path to a resolution. Not sure what other troubleshooting steps to take at this point.


(Joe) #11

I have opened support tickets already. Thank you for trying to help me.

I finally got the app to uninstall, I had to go back into the IDE and enable oauth. Once I did that, I went back into the smartThings app and it let me uninstall it.

I’ll try your Fibaro suggestion tonight. Support also asked me to chat with them on my problems to work through them one by one. Unfortunately I won’t be able to do that until tomorrow.


(Joe) #12

I did the button presses and now the Luminance is reporting again.

THANKS FOR THE TIP!


(sidjohn1) #13

Remove some frustration with this nest device type. It’s been solid.


If your hardware presence sensors are not triggering in a timely manner you may want to shorten the distance between them and your zigbee network by adding a smartpower outlet to your garage. It should start to detect you sooner and behave as expected. If your using the app… Save yourself some frustration and order the key fob. The battery life sucks, but they just work.