SmartThings Community

So Alexa went stupid on me this morning

I unlinked Echo from SmartThings app – then relinked - and told Alexa to disover new things - and she stopped being stupid… hope that helps someone…

Scott Rohling

I’m considering getting an Echo for Christmas. Now I’m wondering if it’s not enough on the polished side yet. How often are y’all having to do this, and how long does it take? Are simple voice commands, or are you having to go thru ST or Amazon screens, entering and reentering? The work involved in reestablishing everything is a key I haven’t gone to hub 2.0 yet. It’s working well, what’s the incentive?

The Echo is great, very easy, very polished. The “went stupid” problems discussed in this thread appear to have been issues on the SmartThings side.

Read the amazon reviews, most people find it both simple and reliable. It’s now the primary means of light control at our house; everybody likes it. :sunglasses:

1 Like

I have 3 echo’s in my house, along the fire tv stick with voice. I’m putting voice control into every room of my house.

It’s very easy to use and it is very very polished. You will not regret it.

1 Like

I am still having issues with echo controlling my harmony activities in smartthings. I know I can use ifttt, but I prefer to say Alexa, TV on instead of Alexa trigger the TV. It works, but Alexa keeps saying that command is not compatible with that device. Saying Alexa, TV off works though, as does switching to other activities once everything is turned on.

Man I really wish I could help you on this. I set up the harmony and only set up watch Netflix and watch live tv. It was about that time I realized this was not for me. My harmony remote is much simpler and faster.

And since I’m already using ST, the harmony hub is just an unnecessary redundancy for me.

I firmly believe in keep it simple, which is why I believe my reliability factor is much higher than the average user.

Good luck my friend. I really believe the harmony hub is great and had a future. I hope you get it worked out.

Alexa has many ‘reserved’ words and they seem to change every now and then (without telling you). I know that ‘TV’ used to work but now I have to use ‘television’ or ‘media center’. Check out this thread

Hey guys, I’ve been using Alexa to control my TV since September and it was working very well… Until they released a TV search Skill which seemed to confuse her. I added Television in the Alexa Alias group list and that works much more reliably… TV seems to be Inconsistent and television is far more reliable.

What and where is the Alexa Alias group list?

It’s definitely not the name, I was just using TV as an example. The same issue occurs regardless of the group name. If I say Alexa, turn Roku on, I get the same error message. However, it turns on and I can ask Alexa to turn another activity on after that and I won’t receive the message. I can also turn it off without receiving the message. She does take an awful long time to say okay though. I think she just doesn’t understand what the device is.

Alias group is just a group name… But what seems to work well is create a number of common names to control a single device. Group Tv= device TV, group television= device TV, group cable = device tv… Common names that you may call the device…

Mike, this may be really stupid but I never say Alexa TV on. I say. Alexa, turn On the TV. I’ll try flipping this around to see if I have issues…

Update: so I have been trying different variations to “turn on the TV” all work consistently well… I occasionally the blank blue ring “stare” but works 95% of the time.

Alexa was giving me the “That command doesn’t work on that device.” During a round a debugging I had removed and then added my device back to the Echo. In doing so, Echo added the device with the same name but was associating the group to the now non-existent device. Told Echo to forget the old instances and linked the group to the new, active device and everything was solid again.

1 Like

I get the “that command doesn’t work on that device” BUT it executes correctly. I go ahead and reissue the command just to try again and it’s ok… She responds, “OK”. So weird. Not sure what the problem is.

Alexa does that to me as well. It seems to happen more during the evening hours. Sometimes she understands “TV” but other times I have to say “Television”.

IT turns out that it’s only a device name issue. Try names with no number and no possible confusion with Alexa’s built in functions.

It seems to help if you put the word lights after the device name.

Complain to Samsung! It’s not Amazon Echo with the issue. Typically it has to do with Samsung crap going down. Checkout status.smartthings.com more more info. COMPLAIN TO SAMSUNG! This has actually gone down twice this week!!

Here’s the situation I have with one device (a lamp connected to a SmartThings outlet). Frequently, I will try to turn it on or off with Alexa and get “Sorry, the device Bob’s Lamp is not responding. Please check it’s network connection and power supply”. If I open up the SmartThings app and turn the lamp on or off, it works. And once I do that, I can immediately control it again with the Echo. I also have a GE appliance module and several GE wall switches, and I haven’t had any problems with them.
Anyone have any ideas?

The SmartThings response to echo is timing out. Since this is just one device, it may be on the edge of your mesh and having to resend its responses to the SmartThings hub two or three times. They’re still getting through, but not fast enough for the echo acknowledgement.

Your GE devices are probably all zwave. They are passing messages between each other, but they would ignore the Zigbee outlet and it would ignore them.

Since this is a zigbee device, how far away is it from the SmartThings hub?