SmartWeather Station Tile device not updating (updated thread title)


(John S) #1

Tried updating the device type code, tried editing config for device. Refresh does nothing. Nothing being logged. Explains why my house lights are firing even though it’s daylight out.

Didn’t bother opening another ticket - lux meter arrived today, will have it integrated this weekend, so at least THIS issue will go away.


(Bobby) #2

What kind of meter did you get? Been trying to use outdoor sensors, but find myself not keeping up with the batteries. And boy they drain quick in the winter.


(Paul) #3

Yes please… what lux meter did you get?


(John S) #4

Got a “Aeon Labs Aeotec Z-Wave Gen5 Multi-Sensor” - will have to see how bad the batteries last, or maybe even consider using it inside.


(Bobby) #5

That’s what I’ve been using…


(John S) #6

I may use it inside, powered off USB. If I go with outside mount I still could probably get power to it if I mount it off the garage.


(Doug) #7

What brand of batteries do you buy? I may be interested in buying stock in them - sales go up whenever anyone buys that one - especially in winter. :slight_smile:


#8

I want to try the Eneloop rechargeable batteries. They’re a little up front but much cheaper in the long run.


(Bobby) #9

The problem with rechargeable bateries, is that you need to change them a lot more often. I tried them…


(Rudi Prunzel) #10

The “Weather Tile” is updated by SmartTiles and it is currently disabled because of the scheduling issues on ST backend. :wink:


(Colin) #11

Mine last updated 1/17… did you get something direct from ST on this being disabled on purpose?


(Rudi Prunzel) #12

More information on the Weather Tile can be found here:


(ActionTiles.com co-founder Terry @ActionTiles; GitHub: @cosmicpuppy) #13

There is a Device Type called “SmartWeather Station Tile” which you may or may not have manually installed in your SmartThings Location.

This has nothing to do with the SmartTiles SmartApp except that SmartTiles support a specially designed “Weather Tile” that uses your “SmartWeather Station Tile” as the data source.

SmartTiles forces a refresh of this data on a different schedule than other Tiles; but that should not generally affect the operation of the Tile (or it’s Attributes) within the SmartThings native mobile App … especially if you are not running SmartTiles.

SmartTiles has currently disabled it’s special refresh of the Weather Tile on your SmartTiles Dashboards while we wait for scheduling issues to be resolved.

If this Topic is not about SmartTiles, then maybe the Title should be edited to clarify this (or vice versa if it is about SmartTiles … is it???).


(Bobby) #14

For the longest time I had an app called ‘Weather Station’ that I thought was setting the sun state for the hub. It was listed under the ‘Hello Home’ group of apps installed. I don’t remember installing it and I’ve always assumed that is a standard app like the ‘Low battery notification’. I tried everything yesterday to get its schedule unstuck, but I failed every which way, so I deleted it. I thought that was this app that John @schettj was talking about.

Maybe Tim @slagle or @jody.albritton or anyone else can chime in to confirm if the ‘Weather Station’ app is indeed critical or not.


(John S) #15

[quote=“tgauchat, post:13, topic:36675”]
If this Topic is not about SmartTiles, then maybe the Title should be edited to clarify this
[/quote]The “SmartWeather Station Tile” device is what I’m referring to, sorry for the confusion. This has nothing to do with SmartTiles.


(John S) #16

And now that logging is working, I see the error:

java.lang.reflect.UndeclaredThrowableException  @ line 164

Which is a call to unschedule()

Wrapping that in a try/catch, and hey presto it started working again.

Weird.


(Colin) #17

wha? english! you modified the device type or ?


(John S) #18

I had made my own modifications to the SmartWeather Station Tile device type (from SmartThings) which for some reason now started to throw an exception

The standard code has this

def installed() {
	runPeriodically(3600, poll)
}

I added another method that I can call from a rest endpoint, which reset the periodic run, but first called

unschedule()

to remove any scheduled stuff. For some reason, that call started throwing an exception. So I just wrapped it in a try/catch block, and now the device isn’t throwing an exception when I tap the refresh button, or when my external service calls it to refresh the weather data.


(Colin) #19

well, that seems specific to your device, I guess. Wonder why the default device type is having isuses, too.


#20

True, The Eneloop’s have a higher ah rating them most and much less of an environmental impact. At 2100 mAh for the AA they’re pretty equal to a long life alkaline. I’ll report back once I get a few.