SmartTiles Dashboard v5.5: Added UK 🇬🇧, 5 × Dashboards, and more! Nov 6, 2015

Momentary is just like an on button to Alexa, although it does a push command.

1 Like

the problem is when i use it on SmartTiles, it runs the same command twice in a row and seem to be causing confusion for my system

Virtual Switches can be a little touchy depending on the SmartApps that use them to, well, link to other SmartApps. (Amazon Echo and SmartTiles are both example SmartApps that can use Virtual Switches to workaround current feature limitations).

That said, don’t stress too much about this particular goal… Dedicated single Routine trigger Tile(s)… I’m going to be experimenting with some code to try to make this a built-in feature of SmartTiles, very shortly.

2 Likes

Would it be better to assign a normal virtual on/off switch to each routine I want on SmartTiles? If “good morning” is ON and someone presses “good night” then what happens? does one routine cancel the other? will both switches still show ON status? Really trying to make this stuff easy so my family doesn’t throw it away,

1 Like

That’s the goal of SmartTiles: Keeping families from throwing away SmartThings since 2014! :wink: :laughing: :speak_no_evil:


Routines are not Modes (even though changing your Location’s Mode is one of the most popular side effects of certain Routines, and is, perhaps, the best way to manage your Mode).

  • A Mode is a single state for the Location at any time. For example, you can be either Home or Away. Indeed, a row of dedicated “mode switches” would have to act like Radio Buttons… i.e., if one is pressed “on” then all the others must flip “off”.

  • A Routine is an action that SmartThings executes once per click of the Routine and then exits. It can be run repeatedly, or, more typically, you run a specific Routine followed sometime by another different one. For example, the Routine Goodbye! could turn off lights, lower the thermostat, lock the door, and set the Mode to Away. The Routine I'm Back! sounds a little like a mode, doesn’t it?, but really is just intended as the opposite of Goodbye! … perhaps it should be called Hello!, but that’s a long story I bet! So the Routine I'm Back! raises the thermostat, unlocks the door, and sets the Mode to … wait for it… Home.

But unlike Mode, a Routine isn’t a “state”. A particular Mode stays “on” until you turn on another one. A Routine is “on” (executing) for a few seconds at most and then is done. That’s what a Momentary Button is for: Push it and you are done. But to make Moment Button’s more compatible with SmartApps that require Switches, a Momentary can imitate a Switch by turning “on” for a, well, a moment, and then turning itself “off”. The problem – to some SmartApps that looks like 2 Events (on … off) instead of just one (push).


SmartTiles treats Routine activation like a Momentary Button. Offering dedicated Buttons for each desired Routine, we might even use icons that are similar to the default Routine icons provided by SmartTiles. Or maybe it should be a little running man :runner:

Routines used to be called “Hello Home Actions” – as in “Hi there Mr. Smart Home, I'm going to bed; ... goodnight!”, hence the legacy icon of a “cartoon speech bubble” still representing the Routines tile in SmartTiles.

1 Like

Okay… so Alex, I know I’ve praised you over PM before. But I had no idea I could pull in direct streams from BI into the app. I always thought video streams were there for the officially supported cameras via ST. So now I’m crazy excited and haven’t even upgraded to 5.5 yet. I may just hold off untill V6. But seriously, this is AWESOME! You guys ROCK.

3 Likes

Be sure to tag @625alex … the real brains behind this invention and its evolution!

2 Likes

Absolutely loving having SmartTiles but a couple of questions:

  1. Is there any way to deal with setting the colour of hue bulbs? Even just like a few presets ala Hue Control app? (I am guessing maybe virtual switch here, but please let me know if there is a better idea!)
  2. I’m using an old Android Tablet (Galaxy Tab 2) and phone (Galaxy Nexus) as control devices but I’m seeing regular redrawing of the page, despite me de-bloating both devices as much as possible without stopping them working… any tips on this front? It’s a bit jarring to have to way for the whole page to refresh on activation just to change a few lights around!

Cheers - James.

SmartTiles isn’t internationalized yet, so we can probably only handle “color”, but not “colour”. Blame Webster. :smirk: … Just kidding… I’m Canadian :maple_leaf:, BTW.

Seriously, there’s no easy way to put full color control in the current design of SmartTiles. We probably need some sort of popout, or “Presets”… Which leads to the current solutions which would be some choice of scene SmartApp and Virtual Switches. Search or wait for Community suggestions.

It’s a bit jarring to have to way for the whole page to refresh on activation just to change a few lights around!

I think a whole page refresh is inevitable when pressing the refresh button to force a poll of untouched Things. But single events be lightweight AJAX and refresh just the touched Tile. My suggestion is to try an alternative Browser App. There’s dozens of off-brand but possibly more streamlined or optimized Android browsers… Boat Mini, Opera Mini, and UC come to mind.

1 Like

Hi All,

Trying to Setup SmartTiles for the first time and get the below pasted error in the browser whenever I run it in the browser. Tried the stock Android browser and Chrome. Another user mentioned adjusting “preferences” to solve this error in another thread but I don’t really understand what that means. Any suggestions?

{“error”:true,“type”:“java.lang.ClassCastException”,“message”:“An unexpected error occurred.”}

I see. The reason I made virtual switches for several routines is that the number of routines is starting to stack up. Also, when I hit the routine button in Smarttiles, the menu of routine options quickly disappears. I have to hit the routines button again. When the menu of routines comes up for the second time I can select a routine, but then the list of routines doesn’t disappear. A bug or something on my iPad. It’s driving my fiancé insane. So I created three virtual switches to represent the three routines she used. Unfortunately the app I used to assign the virtual switch to a routine requires the on and off state to be assigned a routine (as you stated). My system started going crazy so I messaged support. They told me this is causing problems having two routines, the same or different, running that close to each other b

As far as we know, nobody has replicated the “routines list disappears immediately” behavior you are experiencing on your iPad. We definitely want to fix that if we can; but we can’t if it’s just you :confused:. If you know anybody else with similar iPad, you can create a temporary dashboard child and test it’s URL in their browser, perhaps.

The workaround using Virtual Switches is not going to work using the the particular SmartApp you’ve found or chosen. If you want to write a different SmartApp, you need to make it react only to the “on” Event, not both “on” and “off”.

The best solution will be hopefully “soon” SmartTiles feature add that will give you direct support for single Routine Tiles.

2 Likes

Gotcha. Thanks. It’s weird. It does it on my iPad and my iPhone but not my cheap little android tab. I’ll keep my eyes peeled for anyone else with the same issue.

1 Like

v5.4.2’s have been updated to v5.5.1:

The previous version (v5.4.2) SmartTiles.click web installed “singleton / legacy” instances of SmartTiles have been updated by publication “in-place” this evening, to Version 5.5.1, by @625alex.

It is no longer possible to do any new installations of this singleton, but if you have it, you can keep it, reconfigure, etc. … just don’t “Uninstall” or you can never get it back! We will push updates to it along with all the new ones. This is a bonus 6th Dashboard ("[0]") in addition to the 5 you can create with SmartTiles (Connect).

For Release Announcement and a few Release Notes, see SmartTiles.click/News:


SmartApp Icons:

We created new icons to help you distinguish the various SmartApp streams of SmartTiles, though the underlying dashboards are all using the same code:

1. The “legacy/singleton” SmartApp instance that we just updated tonight…
Default name is suffixed with "[0]"

_

2. The new “SmartTiles (Connect)” parent SmartApp than can spawn 5 Dashboards…

_

3. The new child “SmartTiles” SmartApp icon
These will show up (when spawned) in SmartThings mobile App V1 under Labs, but not in App V2 (they are hidden inside Connect). Default names suffixed with “[1]”…"[5]".

_

4. Official SmartTiles basic icon…
If you have SmartApp instances with this icon and various old or crazy version numbers, they are either personal copies of old source code, and/or copies that you installed during Beta testing. These will likely not be updated by us. If they are Beta versions, you probably should consider uninstalling them; they may be unstable.

_


We already have a few hundred installations counted of the new SmartTiles (Connect) released just 4 days ago! Thank-you for the incredible response, everyone; and a special thanks to those who’ve tossed in some voluntary donations.

4 Likes

These statements are confusing me and I am looking for a bit more clarification from anybody who knows.

Does this mean that I can set up separate dashboards for each of my locations/hubs (Home, Vacation Home)? Or does it mean that I can set up multiple dashboards of various configurations for only one of my locations (Home). If it is the latter, is there any way to accomplish the former. I have 2 hubs in 2 homes and would love to use SmartTiles as a UI for both homes/hubs.

  1. Correct: But you need to run the SmartTiles.click/install once for each Location.

  2. Incorrect: You can now set up multiple dashboards of various configurations for any and all of your Locations, even if you only have one Location (Home).

You absolutely can! Let me know how it works out for you…

2 dashboards up and running. One for my house and one for my vacation house. Fantastic!!! Thanks for the clarification and instructions. One small glitch with some video tiles but I will post it in the appropriate thread.

2 Likes

I have a similar issue on my iPad but only in full screen Safari mode.

In Safari, First time I tap routines the popup displays and then disappears. Most of the time, the second time that I press it, the popup stays and I can select a routine and then it disappears as expected.

I cannot replicate the issue in Chrome or in normal Safari mode.

2 Likes

May I ask what model of iPad and iOS version? Any special configuration settings?

We may need someone to donate some test equipment to us … we don’t mind the cheapest model that replicates the problem! Unfortunately, we’re Android and PC people…

I reconfigured, and turned off modes/other items and now get this: {“error”:true,“type”:“java.lang.ClassCastException”,“message”:“An unexpected error occurred.”}

?