SmartThings SmartSensors only recognized as a z-wave repeater

I have two Smartthings Smartsensors, one the newest version, the other is v2. I’ve had them for probably close to a year and not installed them, but now have uses for them. In trying to pair them to SmartThings using the iOS app. When I attempt to pair either one, the hub is recognizing them both as “Z-Wave Repeater” and not as a Smartsensor. I’ve done hard resets on both and tried multiple times with the same result. In the case of the newer sensor, it has a QR barcode to scan and that result is "Multipurpose Sensor (IM6001-MPP), yet it still pairs as a Z-Wave Repeater. On the off chance there is a hub issue, I power cycled the hub and that also did not change the outcome.

Right now I don’t have any other devices at my fingertips to add to see if this is an issue larger than just these sensors.

Any ideas?

Can you provide the model # and which sensors? What is smartsensors? ST sensors should be zigbee sensors so it makes no sense that they would show up as z-wave repeaters.

The multipurpose sensor is definitely zigbee. I am just curious if the other is a multipurpose as well or something else.

Have you tried skipping scanning the QR code?

1 Like

These are both Samsung Multipurpose sensors (sorry, called them smart sensors for some reason). One is newer with the QR, the other is the prior version that does not have the QR. Both are listed as pairable on the ST app. The same result happens with the one using QR, and the other without. In the case of both, I get the Z-Wave response, despite these being Zigbee (and Samsung products, not third party).

The one with the QR is IM6001-MPP; the older version is ( I believe) then STS-MLT-250.

Any custom device handlers in IDE?

Where did you buy them? I’m just wondering if possibly they are counterfeits, that does happen occasionally, for example, on Alibaba, although they are getting better.

1 Like

No IDE handlers at all.

Bought on Amazon.

From a third party seller, or from Amazon itself?

It’s just hard to imagine how a zigbee device could show up as a viable Z wave device unless there’s a problem with the radio itself. :thinking: we have had forum reports similar to that for some locks in the past, but they were the ones that have interchangeable zigbee or zwave or Wi-Fi modules and the product that was delivered had a different module than the product description.

Fun case :slight_smile:

Which hub do you have and what is the firmware version on i?

Just curious as that should not have any impact on pairing of devices.

1 Like

Have you tried to manually change the device handler in the IDE to Smart sense MultiSensor.

when ive had something like this happen the only things that fixed it was to hard reset the hub and rejoin it to my account.

Why do you always tell users to reset their hub? That is the most extreme measure and usually overkill and not necessary :slight_smile:

Just my opinion

1 Like

The hub type is: hub v2, US customer Rev E
The firmware version is: 000.038.00010

As for the IDE - I haven’t made changes there, and honestly not exactly certain of how that would be done.

Correction to my comment a few minutes ago regarding the IDE. Poked around and finally figured it out.

And yes, changing it to the multi sensor worked perfectly. Have never had to do this before, but glad to now know this route should I have issues in the future.

Thanks to everyone for your interest and suggestions!

1 Like

For a few months, anyway. The IDE as well as smartthings-hosted Groovy code are going away, probably by the end of this year.