SmartThings Smart Lock Guest Access - Disappeared (January 17, 2023)

4 posts were split to a new topic: Seam: Temporary Solution for Managing Lock Guest Codes (Jan 2023)

3 posts were merged into an existing topic: Seam: Temporary Solution for Managing Lock Guest Codes (Jan 2023)

A third party company called Seam is offering a temporary solution for managing guest access codes. I don’t know anything about them, but I have moved the posts discussing that option to their own thread, so they will be seen by more people and will be easier to find.

Seam: Temporary Solution for Managing Lock Guest Codes (Jan 2023)



1 Like

Thanks! this makes sense.

1 Like

A post was merged into an existing topic: Seam: Temporary Solution for Managing Lock Guest Codes (Jan 2023)

Just tried this and it worked! Unfortunately, you have to do it from an internet browser.

  1. Login to your hub: Samsung account .
  2. Scroll to “Commands”.
  3. Click “setCode” button to open a dialog to set up your lock code.
  4. Choose your “codeSlot” – make sure you don’t pick a number that is already used.
  5. Choose your “codePIN”, which will be your lock code.
  6. Choose your “codeName”, which will be the name of your lock code.
  7. Click “setCode” button underneath it.
  8. Test the new code on your actual door lock. Make sure you have a way to enter in case you are locked out!

You could always do this via the ST CLI. It was just a little too obtuse for most people. The new Web App Advanced (it really needs a better name) makes it much more straight forward.

1 Like

We haven’t been able to get to the “lock codes” drop down in Smart Things Guest Access for days. Tried two different phones, uninstalling and reinstalling the app, and using the web interface to STGA. Nothing works. We’ve logged a Customer Support ticket with Samsung. We need to remove a code and to add another. Support says it takes 3-6 working days (“24 to 48 working hours”) to get a response. Is anyone else experiencing this issue and is there a workaround for non-engineers other than using the “Advanced” option on the web and systematically deleting every code in every position on the lock and then readding codes one by one (without descriptors)?

There is another discussion with development support on this issue going on in this topic. Suggest you provide the information about your phone, OS, etc that others are providing so they can look for commonalities among those people who are having issues.

You can add/change/delete/name lock code slots using one of 3 methods; the AWA, the ST CLI, or the 3rd party rules engine Sharptools. The AWA is really not as difficult as it may seem. First, you can see what lock code slots the driver thinks are in use by looking in the attributes section for your lock and finding the main.lockCodes.lockCodes item. There you will see a list with numbers and names that correspond to the lock codeSlots and their corresponding codeNames. This lets you see which codes you might want to delete and what codeSlots are available to assign new codes.

With this information, you can then scroll down to the commands section and use the deleteCode to remove the unwanted lock code. You can then use addCode to add a new code with a name.

While the ST CLI can accomplish the same thing, it’s even less “non-engineer” friendly :slight_smile:

Thank you very much. I’ve succeeded in removing the correct code with AWA with the instructions you gave here which is a relief. I have provided logs to Support too.

1 Like

Eventually after 3 weeks of providing logs, etc., SmartThings support got back to me with a real workaround. Apparently the problem was caused because there was an inactive, “hidden” lock in my account (it’s an old one I had thrown away). I had to “unhide” that lock for the “lock codes” option to come up again and be usable for my real lock. So if that situation applies to you, do that!