Smartthings not recognizing motorized window shade

Hi. I had an earlier post about connecting my Signature Series motorized shade from Budget Blinds as well as a Somfy 2 button remote. Here is a link to that post:

I was given great instructions on how to get both devices successfully connected to smartthings. That worked for a few years, although off and on Alexa and Google Assistant would say the device is offline. After a while, the blind was simply off the network and was not visible in SmartThings.
So I tried the following steps that were given to me in that original post:

  1. Reset remote. Press and hold the pinhole button at the back for about 15 seconds. Will cycle through green, amber and red and finally no lights
  2. Add shade to ST (Press and hold button on the motor for 3 seconds while ST is searching for zwave devices)
  3. Add remote to ST (Press and hold the pinhole button at the back for 3 seconds while ST is searching for z-wave devices)
  4. Once remote and shade are both added to ST. Press and release the pinhole button on the remote, it will start flashing
  5. Press and hold the button on the shade for 3 seconds

The blind simply could not be found by SmartThings. To ensure that I was doing things correctly, I tried to just add the remote using step 3 above. SmartThings found it almost instantly and added it.
Each time I try to add the shade, The light on the motor blinks after pushing the button for 3 seconds. SmartThings scans and scans and then just says it cannot find anything and the light on the shade stops blinking.
Given this is the first smart shade I have owned, I do not know if there is any way to diagnose why it cannot be seen by SmartThings. At this point I am just assuming that the network capabilities of the shade are gone and this is no longer a smart shade. Just in case there is an alternative explanation I thought I would reach out here.

Thank you for any help you can offer on this issue.

You will likely need to ZWave exclude the shade before it will be able to successfully be re-added. The shade likely currently thinks it’s attached to a network so it won’t attach to another until it’s removed. You’ll need to look for exclusion instructions for your shade.

Thanks @nathancu for that suggestion. Based on that i did find a site to help me, and the exclusion of the blind and the associated remote worked as advertised. After the exclusion of the shade the shade jogged up and down slightly to tell me it was removed feom the network. Here is the link for anyone who may have the same question.

I then went into smartthings to add the device. I tried multiple ways to add the device with no success. The blind goes into learning mode by holding down the button for three seconds until the light blinks green.

  1. I tried using ST option to scan for nearby devices. After about 20 seconds the blind stopped blinking and ST never found it.
  2. I tried to add generic zwave device. ST went to a screen that said ‘preparing’. I put the blind into learn mode again and after 20 seconds it stopped blinking and ST eventually said something went wrong.

Option 1 above worked perfectly for the remote so the steps seem accurate.

Is there another way for ST to find the shade once it is in learning mode?