SmartThings + Google Home = Switches become Lights

wemo
googleassistant
googlehome

(David Dachenhaus) #1

I have had this issue for awhile now, and I just can’t seem to get it figured out. I have a SmartThings Hub with 4 Wemo Switches added. I don’t have the switches added to the Google Assistant directly, only through the SmartThings hub. I have 2 of the Wemo Switch Smart Plug and 2 Wemo Mini Smart Plug. I have only one of them worded as a Light and it shows up as a light in Google Assistant. Now the other 3 I have setup to Fans. Out of the fans only 1 shows up as a switch and not a light for some reason. They all follow the same naming scheme. I have them all added as so Living Room Switch or Bedroom Switch. I have seen posts about this before and how the naming of devices matters.

I had two fans plugged into switches, one named Bedroom Fan Switch and Living Room Fan Switch. The Bedroom fan showed up as a switch while the Living Room Fan Switch shows up as a light. I can say turn on Bedroom Lights and the fan there does not turn on, but if I say turn on Living Room Lights the Living Room fan turns on.

I am at a loss to figure out why these are doing that and how to get Google to see the devices properly.


(David Dachenhaus) #2

Couldn’t add a second photo, but here are the same ones in the SmartThings app.


(Mark) #3

Any reason you prefer to have the wemo switches linked to google through ST?

I have Alexa devices, but with some Lutron switches/dimmers I just added them directly to Alexa, even though they’re also linked to SmartThings.


(David Dachenhaus) #4

Better integration using IFTTT. The only other way would be to have them linked through both, which then they show up on the Google Home app twice.


(Mark) #5

Couldn’t you authorize the devices in the IFTTT integration smartapp, but not the google home integration smartapp?


(David Dachenhaus) #6

I have the switches going through SmartThings because of the API integration for my Nest Thermostat. I can’t remember how I set it up way back when, but I thought that went through IFTTT, maybe not. That is the only reason I have the switches added into SmartThings instead of adding my Belkin Wemo account into Google’s App. The plan was to have SmartThings turns fans/window ac units on/off depending on the temp inside.


#7

I think the question was why not directly control from Google Home to Wemo? If you go into the GA app and go to add device you can select Wemo from that menu. It might work better than going through ST.


(David Dachenhaus) #8

I can try it this weekend, but I’m pretty sure ST couldn’t see the switches if added to just my GA account. I need ST to see the switches so they can be controlled by my Nest Thermostat. If they are added to both GA and ST then I have the same issue I have now, not to mention the devices are then duplicated.


#9

No, because in ST you can choose which devices to expose to Google.


(Mark) #10

Sorry kinda lost track of this thread.

@Ryan780 is indeed getting at what I was asking.

Consider doing the following.

  1. Connect your wemo switch to ST in the mobile app (you’ve already done this).
  2. In the IFTTT connect smartapp in the ST mobile app, authorize your wemo switches and whatever else you need to (you’ve already done this too).
  3. In the google home smartapp in the ST mobile app, de-authorize your wemo switches so that google home no longer sees them through ST
  4. In your google home app, install the wemo skill (or whatever it’s called, I use Alexa devices as I mentioned), so now your google home can see the wemo switches directly, not using ST as an intermediary.

I’m not exactly promising that this will help, but by taking ST out as the intermediary between wemo switches and google home when it wasn’t really adding anything in the first place, you may get the behavior you’re looking for?


(David Dachenhaus) #11

@marktheknife @Ryan780

Thank you guys. I will give this a try this weekend. I was unaware you could make it so ST wouldn’t pass certain devices to GA.


#12

Yup, go into the Google SmartApp in the ST app on your phone. There’s a switch to turn off the “all devices” option which is checked by default. Then you can pick the ones you want ST to pass to google home.


(David Dachenhaus) #13

@marktheknife @Ryan780
Wanted to report everything is working perfectly. Thank you for the suggestion!