SmartThings Edge Developer Beta | Known Issues and Bug Tracking

@DJFliX I have a driver for this device (Aqara tvoc by varzac · Pull Request #6 · varzac/EdgeDrivers · GitHub) and I am getting values as I would expect.

<ZigbeeDevice: b2ede2e6-6eff-47c0-afee-99ca23474e89 [0xC4F2] (Aqara Air Quality Sensor)> received Zigbee message: < ZigbeeMessageRx || type: 0x00, < AddressHeader || src_addr: 0xC4F2, src_endpoint: 0x01, dest_addr: 0x0000, dest_endpoint: 0x01, profile: 0x0104, cluster: 0x000C >, lqi: 0xFF, rssi: -52, body_length: 0x000A, < ZCLMessageBody || < ZCLHeader || frame_ctrl: 0x18, seqno: 0xE3, ZCLCommandId: 0x0A >, < ReportAttribute || < AttributeRecord || AttributeId: 0x0055, DataType: SinglePrecisionFloat, SinglePrecisionFloat: (1 + 0.589844) * 2^(9) > > > >

So without more specifics it looks to me like your device is actually reporting a 0 value. However, it is a bug that value.value is not doing the special handling of a 0 report which is why that event is showing that really tiny non-zero value.

1 Like

Awesome, thanks! This was my first (attempt at) an edge driver so it’s nice to see that I at least got some stuff right. I’ll keep an eye on that edge channel so I can try out this driver to see whether my device is faulty. Chances are I messed up elsewhere in the driver and the device is working perfectly fine :sweat_smile:


Since yerterday, I can’t access any edge drivers channel via web or from the app. If I can access it from the CLI.
Users cannot access my shared channel, I don’t know if to other channels can.

From the CLI and the app I cannot access the drivers installed in my HUB, but I can change the drivers in the devices by clicking on the proposed drivers. The magnifying glass does not find drivers installed in the Hub

I have tried to reboot and shut down the hub several times and the problem persists



Hi! I was able to replicate the issue with the web page of the invitations. I’m already in contact with the engineering team about this. As soon as I get an update, I’ll share it with you.

About this, do you receive any error in the CLI? I got the 403 error but I just want to confirm

1 Like

Yes, 403 Code error

The engineering team already solved both issues, let me know if you’re still having problems


From the app I can now access the hub drivers and all the channels.
From the cli, I’ll try later, now I can’t

UPDATE: with CLI works fine too


1 Like

Regarding the new beta ‘Zigbee Button’ driver when used with the ‘IKEA On/Off Button’ (two-buttons-battery).

  1. Unlike the DTH there isn’t a button capability in the main component for legacy purposes. That’s fine by me but it does mean that there isn’t anything to display in the dashboard tile other than the battery level. Obviously we have to start somewhere but I think that needs addressing.
  2. Unfortunately the battery level is half what it needs to be. Unsurprisingly I had to change the batteries in both my buttons before installing them so they should really be showing 100% but IKEA is quite enthusiastic about 87%. The driver is reporting 44%. I believe we saw that with other IKEA devices using Edge drivers.
  3. Thank you. Just a pity the IKEA buttons are currently useless because of their battery problem.
1 Like

4 posts were split to a new topic: [ST Edge] Issue with the Z-Wave Switch driver

Please send me over DM the following information:

  • Screen captures of the issue.
    • For 1, the comparison between what you should see and what you actually see in the ST app. What do you mean by "there isn't a button capability for legacy purposes"?
    • About 2, did you check the Hub logs to see the value that was reported by the device? I mean in the reporting messages. It would be useful if you shared the logs when the battery is reported, to see if the value received is correct but is not calculated properly.

I’ve gotten a firmware update to 000.041.00004 and am getting a new variation on the previously reported cosock bug:

Lua: runtime error: [string "runner/src/"]:296: cosock tried to call with no sockets and no timeout. this is a bug, please report it
stack traceback:
	[string "runner/src/"]:296: in field 'run'
	[string "runner/src/"]:743: in method 'run'
	[string "init.lua"]:341: in main chunk

This happens when I try to update an existing driver that utilizes cosock. It repeats over and over infinitely as it keeps trying to restart the driver. The driver uses a TCP socket and has one channel handler.

5 posts were split to a new topic: [ST Edge] Devices stop reporting values after firmware update

A post was split to a new topic: [ST Edge] Issue with HTTP request in Edge drivers

Thank you for sharing this @TAustin. I already shared your comments in the previous report on the issue. Once I receive an update, I’ll share it with you.

1 Like

A post was split to a new topic: Issues changing the default range of a stock capability

New channel invitations aren’t showing in the CLI when running edge:channels:invites. The ones that aren’t showing all have the new URL format of

Thank you, @philh30, this is a good catch.
I could replicate the issue, so, I will report it to the engineering team. In the mean time, I suggest you save the invitationID every time you create one because we can still get its details with the following command:

smartthings edge:channels:invites invitationID

A post was merged into an existing topic: [ST Edge] - Fatal error from socket.http

Will hub firmware 0.41 be released soon?
I’m still having this cosock error with the zigbee edge driver (on my V2 hub firmware 0.40.6).

btw, Happy New Year!

1 Like

The engineering team said it will be released in early January.
Happy new year to you too! :partying_face: