Smartthings cannot connect to more than 1 WeMo switches?

I bought 2 WeMo switches. I was able to add either of them but cannot add both. Smartthings app is only able to detect 1 switch. If I remove the one from the app and unplug the 1st switch, then it will be able to detect the 2nd one.

Any idea how to fix this issue?

Are you using the WeMo (connect) app?
I find this works for me.
If not just search the forum for it.

Yes. Both switches show up in WeMo (connect) app. But only 1 can be detected by SmartThings app…

Sorry but I don’t really understand what you are saying.
Either you can see it in the Smartthings WeMo connect app or you cannot.

I can see both switches from WeMo app. Samsung’s SmartThings can only detect 1 switch. Say, WeMo Switch1, but cannot see WeMo Switch2 at all.

If I remove the WeMO Switch1 from SmartThings app, and unplug this switch, and then try again via MarketPlace->SmartThings Labs->Belkin WeMo Switch(Labs)->Connect Now, then it will be able to find WeMo Switch2.

In other words, SmartThings can only found 1 switch, no matter how many of them are actually online and available…

Hope this no longer confuses you…

I am currently using 2 Wemo light switches and 1 Wemo plug.

The only critical thing, which you’ve already done, is to set them up in the Wemo app first. Then you should be able to see them in the ST app when you tap Add a Thing from the Things view.

Try adding one. Rename, then tap Save. Once this is completed, go to the other and tap Add a Thing. While the ST app is searching, unplug the Smart Plug then plug it back in (or power it off, then on again).

If this doesn’t work, you might have to reset the Smart Plug. You can follow the manufacturer’s instructions for that.

Today, WeMo pushed a firmware update. After the update was done, I tried again. Surprisingly SmartThings app was able to found both switches. So I added them both into the SmartThings app. Unfortunately, now both switches are showing ‘OFFLINE’ under ‘My Home’ tab. Tried all the possible way to refresh but both still ‘OFFLINE’, while the WeMo app shows both switches are online and functioning.

Then I have to remove both of them from the SmartThings app again, and tried Connect again. Now again it could only find one switch…Very frustrated.

I believe my setting is OK but for some unknown reasons it is just not working.


Use this

Glad it worked out in the end with the firmware update. I was just about to say to throw away your wemo junk and get something else like ST or TP-Link. I’ve never come across anything as unreliable as Wemo stuff ever before!

Hi, the wemo app from smartthings does not update the ip, and crash if the timers down (very common) , if you have problems in device off line, try the wemo advanced, just remember to uninstall the wemos and start over.

Thanks for your info. Unfortunately, still no luck.

Do you mean that there is a app called “WeMo Advanced”? I was trying to find the from Google Paly but could not find it.

I also tried uninstalled WeMo app and reinstalled it, but still pretty much the same. Currently I can see both switches (named switch1 and switch2) from WeMo app. From SmartThings app, MarketPlace->SmartThings Labs->Belkin WeMo Switch(Labs)->Connect Now, it can only detect 1 switch (as switch1), when I go back to ‘My Home’ tab, it shows ‘switch2’, and it actually can only control switch2 on/off. Sounds to me this is a bug of SmartThings, not WeMo.

Hi @zwy8899, There is a smartapp for smartthings called “Wemo advanced” to correct the problem with the original wemo app from smartthings, you must install it from the IDE, the connect and the devices handler, if you don´t know how to install smartapps for ST I suggest you to read in the forum.

I did search the forum, I even watched the 2 hr video which shows how to develop and publish smartapps, but still no clue how to install the “Wemo advanced” from IDE.

From the IDE, I can see my location, my devices, but nothing is under ‘My Smartapps’:

You don’t have any apps yet. Add one now.

I browsed the documents, and seems like I should be able to see the app IF I published for myself, but I do not see how I can find other people’s app and how to install them.

Could you kindly point me to the instruction, or outline the steps as how to install and setup “Wemo advanced”?