Smartthings Button is always shown as Offline (April 2021)

Hi Guys,

i’m new to the smartthings community and need some assistance and hope someone is able to help me with a crucial problem i can’t solve myself.

First of all, i bought a couple of days ago a smartthings hub, it’s the Samsung v3 version.

With the Hub i also bought a Smartthings button and some other stuff. Before i switched to smartthings, i was familiar with zwave and used an almond hub.

Most of my zwave stuff i could include easily but the smartthings button is a hard challenge.

The inclusion process is working fine, but the button is always shown in the app as offline! So i’m not able to create scenes or “actions”. If i remove the batterie and put it again into the butto, the button’s led is green (for 5s or so), during the led is green, it shows the button as online but then it changes back to offline again :frowning:

I tried following steps:

  • excluded sensor and included again (5x)
  • used a new battery
  • restarded the hub several times

Nothing helped. When removing battery and restarting the button, i tried to set an “action” because then it’s not grey in the app, but saving the changes results in an error.

Any suggestions for solvin this problem?

The weird thing is, that if i push the button, it shows it in the app correctly, also the temperature…

You aren’t alone.

1 Like

Hi Nathan,

Thx, it seems to be a huge zigbee problem. Just wanted to add my ST Water Leak Sensor, it’s also a zigbee based sensor. Same problem :frowning:
All my zwave sensors are working pretty fine but not the smartthing stuff, this is ridiculous!

In ide the sensors are online, wtf? It also sends me a message when it detects water but i can’t do anything, also renaming is not possible because it’s offline.

1 Like

exactly - its not just zigbee either - appears to impact any new device added within the last day or so

3 Likes

While disappointing… this is good to know… @nathancu @Racer1982

I have just purchased and added to new devices to my smart things network
GE ZWAVE Plus Toggle
Ecolink Motion sensor
Both are able to be added yet both SHOW OFFLINE.
Weird part is they show the status changes and seem to generally work. I set up an automation in the ST App to turn the light on when motion is detected and it WORKS.

Biggest problems though

  • I cannot rename the devices show they show as DEFAULT names - GE Switch, Ecolink Motion
  • I cannot control the devices through ST App. (Turn off/on the light, or update other settings)

Hoping this gets resolved quickly.
This is a V2 Hub and screen shot of firmware attached.

FURTHER… I cannot get these to add to alexa or home due to the offline status as well…

GRR

Yep that’s exactly the problem. Groovy IDE sees the device and status, NewApp infrastructure doesn’t and marks the device offline.

1 Like