Smartthings App v1.7.99.21 cannot grant permissions for storage

I am using an S22 ultra running Smarthings trying to upload images to my Samsung QN75Q9FNA (2018 model).

In smarthings, once connected to the tv via the app on ambient mode settings, i am selecting “select photos” but then receive the message to grant permission for storage in my smarthings apps settings. There is no option for “storage” in the permission settings. I have granted permission for all of the other available options.

I am at a loss, but it seems like the app has this option to upload my own images and yet the software doesnt actually support it.

Any ideas?

I think the Android “Storage” permission is now more granular. Try granting the “Photos and videos” permission instead.

1 Like

I have the same issue. I’ve tried uninstalling the app and reinstall, doesn’t help. I’m on Android 13 which has different privilege settings. Works fine on my Android 8 phone because it has a specific “storage” permission.

My assumption is the MyAlbum feature needs to be updated for the latest Android version.

I’ve given smartthings app permissions for everything yet still displaying this error message.

Looks like this issue has been fixed. Thanks Samsung /Smartthings!

How you solved the problem? I am still having issue with “Grant permission to files” on my Xiaomi redmi note 12 pro. Tx