Problems changing wallpaper to existing image on Android

I am trying to change the wallpaper for my existing locations. I can choose one of the pre-defined colors in the top section, and I can use the Camera option to take a new picture. However, I can’t use the Gallery option to choose an existing picture from my phone. Whenever I tap on the Gallery option, I get a toast that says You don’t have any apps for selecting images. Install one first to change the wallpaper.

I’m running v1.7.73.22 of the Android app, last updated on October 23. I’ve tested this using stock Android 12 on a Pixel 5A and also using stock Android 11 on a Pixel 2. I’ve confirmed that the SmartThings app has the Files and Media permission set to Allow access to media only. Other apps seem to have no problem picking images off the phone. Is this a bug in the app, or am I missing something?

Hey there! @kpronovici, Gallery uses the user allowed Storage permission to access files, media, and photos on the device.

I just tested the resetting of ‘Storage’ Permissions under Settings>Apps>SmartThings>Permissions>Storage>Select Deny.

Once you have denied the storage permissions, return to the ST APP and re-add the storage permission by attempting to select the ‘Gallery’ option under wallpapers for your room/location.

I hope this message finds you well!

^SamsungZell

Hi,

Thank you for the suggestion.

On my Pixel 5A running Android 12, I see 4 permissions under Settings > Apps > SmartThings > Permissions:

  • Camera
  • Files and media
  • Location
  • Nearby devices

There is no permissions entry for Storage.

I did try changing Files and media to deny. When I clicked on Gallery back in the SmartThings app, it prompted me with “Allow SmartThings to access photos and media on your device?” and I chose Allow. However, I still got the same error message after that.

I’m having the same problem too on my Pixel 6 Pro. I also have a device running an older version of Android (I think it’s 10, it’s a Huawei and it’s hard to tell. On the older version of android I can use the gallery just fine. And just in case I installed a 3rd party gallery app. Still have the same problem on the Pixel.

It makes me wonder if the ST app didn’t take into account android API changes. That could explain why it’s not working on newer versions of Android but does work on older versions.

Yeah, that is what I am beginning to think - the permissions model changed in newer Android versions, and the app doesn’t take that into account. I also tried a third-party gallery app.

Same problem, OnePlus6 with OxygenOS 11.
Tried clearing storage of both gallery apps and SmartThings, same result.