Cannot grant storage permission

Hi, I’ve tried googling, uninstalling and reinstalling, clearing cashe, and I’m just at a loss.

I’m on a Samsung S21 Ultra (android version 13, one UI version 5.1), and I cannot find storage permissions anywhere. I have all permissions available marked as “allow”.

I’m trying to set up the ambient mode and choosing my own pictures, but every time I try, I get this message. I tried sharing photos from my one drive to my TV, and it took me to the smartthings app and gave me the same message.

I’m at a total loss of how to fix this if I’m being honest. So really hoping someone here can!

there was a recent thread. it might be related to Android 13 so may need to see if future app releases fix it. :man_shrugging:

do report the issue to ST support

I just reported it (something I should have thought of immediately lol). So hopefully somehow in the future it geta fixed.

I don’t see storage permissions literally anywhere, even in the developer settings (had no faith in finding them there, but checked anyways). I like the photos provided for ambient mode, I just wish I could customize them with my own.