SmartThings app TV remote

After the last app update, the touchpad to control the cursor on my TV is not working as intended. It’s moving the cursor like I am using the remote’s directional arrows which is a slow process and it’s quite annoying.

I tried deleting app cache, data & re-install app, but the issue persists.

  • SmartThings 1.8.13.22
  • Android 13

I’m not sure if I can be of much help, but the first 2 things I would try are 1. Semi-hard reset the TV; you can do this by either unplugging the TV then replugging it in about 30 seconds later or easier yet; start the TV and after it fully boots hold down the physical remotes power button until the TV restarts (you see the screen produce an image which will usually will be OLED/QLED/Samsung or something similar). What this does is basically act just like you restarting your comouter or phone when it acts up clearing the bad acting program just in limbo. If this doesn’t work you can number 2 always go to your TV’s settings menu and then go down to support. You should see an option called device care click this and run it. This clears the cache of all the apps on the TV and could possible fix the issue if their is a corrupt file or file causing it to lag speeding it up.

If these don’t help, I would like to ask what version of the app were you using before? I ask as awhile ago they changed the app’s remote function to look just like the TV’s remote sometime the middle of last year. Before this it only had a touchpad mode. The new version has a seperate button that always you to change between a standard click remote and slide touchpad mode (see attached photos below of new app remote; old remote looks like the one from this post: Q70R Smart TV - #8 by DaWeav).

If nothing I said helps fix it I would then suggest you contact Samsung through their Members App or on the phone to try to escalate the issue with support.


I tried first option multiple times but it didn’t fix unfortunately. There is no ‘device care’ option on my TV (7 series) but I cleaned both cpu and ram from TV device manager which didn’t fix it either.

I am not sure what was the previous app version but all worked fine until the update on March 7th was released and it also installed an add-on for my TV which ended up messing the touch pad.
I have the old remote…

Okay, I see, your “Device Manager” is the same as the newer “Device Care” I was talking about. I have found a forum post on Samsung’s main page where someone had a similar problem and they fixed it by factory resting their TV, which you could try and if it works then your all set to go (Solved: Recent Update to SmartThings broke the remote cont... - Samsung Community - 2488842).

I really think though is you have ran into the problem I have with my oldest TV (2017 model) is that your TV in layman’s terms is too old for the newest version of SmartThings and is no longer supported, so the remote features will no longer work within the app. I know older models are no longer in Smartthings and according to JDRoberts a highly respected and knowledgable forum member; models from 2018 and older are no longer supported and this decision was made last year as seen in his forum post here: (Is Samsung SmartThings Discontinued? (Jan 2024) - #2 by JDRoberts).

Also I’m not sure what model you have as there are two different 7 series that I can think of (three to be exact); the 7 series flat QLED, 7 series curved QLED (Which I had and died, also it wasn’t supported anymore in SmartThings and was identical to the flat model except the screen was curved) and many UHD Crystral display 7 series. All 3 of these seem to be 2018 or older to me and wouldn’t be supported anymore.

I could be wrong that other models exist, but I’m unaware of them and can’t narrow down your model year without the full model code.

1 Like

Model UE50 RU7172 released in 2019.

Sadly, I can’t tell you for sure if your model still works with SmartThings as I’m in the US and the app will only show me TV models that are compatible only here not ones in the UK. But considering it is a 2019 model and has worked in the past I’m thinking something got corrupted on the TV. If you have the physical remote, does that work if you hold down the directional buttons? I ask as one of my 2020 TVs had a remote problem where you could only increase or decrease the volume by one click of the remote evenon the app. If you held the volume button to quickly change the volume it wouldn’t work. It would work with an old fashion IR remote though, which i had a Logitech Harmony remote that worked just fine. Like you I tried everything and after reading a factory refresh helped another user, I reset the TV as a last resort and magically it worked again.

Another thing make sure your firmware is upto date, I see that there was an update release a month ago and sometimes the update within the TV’s settings doesn’t get linked to the update and you will have to manualy force it via a USB device. If not updated this could be one thing that could fixe your problem.

The next thing I was able to find a forum post on here saying that something very similar if not exactly the same happened in 2020 here: (SmartThings app TV remote control). It looks like it has never been fixed and due to the fact that your model is still using the old remote it may not be fixed. I can’t say what the developers will and won’t do as us forum members are mostly (about 99.99%) customers like you. Sadly, all I can say is do 1 or more of 3 things, factory reset your TV and see if that fixes it, contact SmartThings developers by going to the menu within the app and clicking “Contact us” and describe your issue (remember though you will more than likely only get a tier 1 support person and it may take a while to get your issue escalated to the right department if at all and they may or may not do anything even if it is escalated. This has been my results for a few issues I’ve had.), then sadly you can just try to live with it.

I’m sorry I can be of much more help. I really do wish I could do more, but all I can do is give advice that most of customers have tried for an issue like this.

Yea exactly, that bug with volume is also occurring to me, holding it down doesn’t work anymore.

Any idea where is the section to manually install updates? I want to try anything else but factory reset tbh

Here is the link to your model: UE50RU7172U | Samsung Support UK.
Also, just one more thing if you have to factory reset, before you do, check your Samsung Account on the TV and open it. I know my 2017 has limited options, but my two 2020 TVs have about 8 options including an option to back up the TV. Here is Samsung’s link talking about all account options: Use a Samsung account on your TV or projector. I don’t know if you will have access to this option, but if you do this option makes it so if you have to factory reset the TV it gives you the option to restore the TV back to the way you had it just before the reset automatically instead of having to setup everything from scratch. FYI, it does take about 30 minutes to an hour to restore these setting though as it has to reinstall all the apps you had and maybe longer if you have slow internet. Anyway, for this to work though you must have the backup option setup and your Samsung/SmartThings Account(s) must be linked. When you go to re-add fhe TV to SmartThings it should then ask you if you want to restore from a back up, say yes and choose what you want to be restored (it may give you more then one thing to restore). It should also tell you when the back up was done in this setting, so if the backup date is recent you should be good to go to factory reset if you have this option and need to do this.

Hope this helps.