SmartThings app on iPad 6th gen does not work


(Tom Guelker) #1

I searched for this, and found nothing.

Last week I received a notice on my iPhone 6s that a new Samsung app was available, I allowed the download and install. It works fine on my iPhone, but it does not allow me to logon from my 2018 9.7" iPad . It worked fine a week ago. Any ideas what I did wrong? If this was a common problem I would expect it to be mentioned here.

I uninstalled both the Samsung app and the SmartThings app and reinstalled them with the same results. It tries to log me on to us.account.samsung.com and then it just sits there. This is with both the classic app and the Samsung account.

I can’t believe that no one else has this issue.

Thank you


(jkp) #2

On your iPad, go to settings, scroll down to find safari. Scroll to the bottom find Advanced. Click on website data. Do a search for both smartthings and Samsung and delete any entries for them. Then open your ST app and choose new user and then select your Samsung account.


(Tom Guelker) #3

Thank you for the reply. I did as you suggested and still have the issue where the app asks for my email address so I enter that and then it goes to us.account.samsung.com and just sits there. I have emailed Samsung and hope they have an idea.


(Tom Guelker) #4

It is working again! I restored from a month old backup when it worked and I still could not logon. I reset the iPad and did not restore from the backup. I installed the app and now it works. Something in Safari was really hosed. Next I am going to restore from the backup and see if can figure out WHAT is hosed in Safari. It would take me a week to reinstall everything so I am hoping I can fix the issue with Safari.
Thanks to all for the posts and emails. This community is very helpful.


(Tom Guelker) #5

Somehow javascript was dsabled on my iPad. I enabled it and all it well. Thanks!