SmartThings app language issues when connected to washer

Hello, I was instructed on Samsung support forum here: com/t5/Samsung-Apps-and-Services/SmartThings-app-language-issues/m-p/2882023#M105148

to post my issue here regarding SmartThings app I have encounter and I will try to be precise as I can be.

Steps to reproduce:

  1. Install SmartThings app on Samsung S23 Ultra (In my case it is model SM-S918B/DS)
  2. Set phone language to English US
  3. Connect your washing machine with SmartThings app( in my case it is model: Samsung WD80T554DBW/S7 )
  4. Open SmartThings and then click on washing machine to view washing programs and pay attention on names of washing programs as they are displayed properly as seen in images bellow:

English 1

  1. Now switch phone language to Serbian latin ( native: Srpski Latinica )

  2. Open SmartThings app and click on your washing machine to open and see washing programs

  3. You will notice that names of washing programs are not shown as shown in images bellow:


I had the same issue starting from S21Ultra up to the current phone and same issue was displayed on my old iPhone 12pro max I owned.

Basically when I switch phone language to my native Serbian Latin SmartThings app does not display names of washing programs of my washing machine.
Please let me know if you need any additional information’s in order to solve this.

Thank you!

If I had to take a guess - I would say it could be either of the following; 1) a bug with your native Language in the app or 2) some type of display issue involving your native Language such as text size is too large for it to properly display in those fields in the app or 3) none of the above :slight_smile:. Again, I don’t know. You can try adjusting the text size temporarily under your phone settings to test #2 (you can always switch back to your original settings after testing).

If no one else on this forum is able to provide you with a solution… I would recommend contacting Samsung Support directly to report the issue to them. In the SmartThings app - tape on “Menu” and select “Contact us” and next “Error Reports”. You will probably want to select “Something Else” or “Device Control” on the “What is the error about” screen. Send error logs if that option is presented. Hopefully they will reach out to you (support in Europe has probably been lacking :man_shrugging: :man_shrugging: :man_shrugging:). If other contact methods are available besides “Error reports” you can also consider those

Sorry that you are being redirected yet again and hope you are able to resolve it. I saw your other post on the Samsung community forum and the email address is no longer valid.

1 Like

Also check Smartthings Dashboard or Advanced Web App to see if the washing programs are available.

Hey jkp, thank you for answer. I just tried #2 with changing font from smaller as you suggested to largest same result titles are not visible.
I will try to report this again but so far yes support in Europe is truly lacking mildly said.

Thank you for guidance regarding this matter.

oops - change from a larger text to smaller text. again, I doubt changing the font size would make a difference but always fun to test.

I wonder if @Mariano_Colmenarejo may have come across any issues involving Serbian Latin (ha ha not text size though in the app… just wondering).


It seems like a translation problem in the presentation of the capability since it also fails in both iOS and Android apps.

1 Like

Nope I see only some codes when I visit those links.

Tried every combo don’t worry. It is not showing titles.

Yes unfortunately, you are probably correct.

I have reported this error (again) and yet again got this generic response. I truly think that someone is just dissing these reports.