SmartThings App Error Trying to Connect Harmony Hub (Google Authentication)


#1

Does anyone know how to get around this error? When I try to add my Harmony Hub to SmartThings, it states to login to my Logi account to allow SmartThings OAuth to Harmony. I used Google authentication to create my Harmony account. When selecting Google, it appears Google now no longer allows OAuth except through a web browser. I get this message.

  1. That’s an error.

Error: disallowed_useragent

This user-agent is not permitted to make an OAuth authorization request to Google as it is classified as an embedded user-agent (also known as a web-view). Per our policy, only browsers are permitted to make authorization requests to Google. We offer several libraries and samples for native apps to perform authorization requests in the browser.


Harmony and smart things app
(Paul James) #2

Same issue any help?


(Bill S.) #3

I ran into this awhile ago and had to change my auth from Google Auth to email. Since then, I’ve not had any issues.


(Kyle Bicking) #4

Did the trick thanks!


(Paul James) #5

It did work.

Thanks for the help.


(Alex Ledesma) #6

Hi guys, how did you guys actually do this? I can’t find where to switch my auth type.


#7

Any updates to this? I’d love to get Harmony set up, but get this error as well. Can’t find a way around it.


#8

I am receiving this exact same error. How can it be fixed?


(Paul James) #9

Can you just change it to authenticate via email instead of gmail. or is there some reason that you need it to be google authentication.


#10

The only way I found to change from Google to email was to logout of the
app. But you can’t log out of the Harmony app. So I cleared that app’s data
then opened it again. I clicked forgot password and entered my Google email
address. Once I followed the password reset procedure my account was now
email based and no longer tied to Google authentication.


#11

I found easy instructions on how to change your account over to email here:
https://support.myharmony.com/en-us/how-to-change-your-email-or-user-id


(Seth James) #12

Ran into this today and this article saved me - thanks!
Below is the URL to Logitech’s site on how to change it.


(Brandon ) #13

Hey guys, just ran into this issue again today. I tried the method posted by lunged but on my end, there was no option to “change email”. I could update it, but now physically change it. So through the harmony hub software on my PC, I clicked forgot password. Used my original email, new password, and now its all working. Just for the next guy who runs into this problem.


#14

I can’t get through the credentials input. When I try to login with my login and password, it says they’re incorrect (even though they work on the Logitech website). When using Google, I get the browser disallowed error. Any ideas?
EDIT I used Facebook and it worked.


(Brad) #15

Having a different issue with this Smartapp today and can’t find the new topic button so hopefully someone sees this.

Using classic app, had removed the Harmony Connect smartapp completely as I was clean slating. Now, when I try and and it back in, it spins a VERY long time, then just stops. THe app is there but it just spins for a second and will not load the settings screen. Nothing in live logs or anything. Since it won’t even go to the SmartApp screen the only way to remove it is using the website. Did this 3x now, for whatever reason it seems like this SmartApp doesn’t want to install. Coincidentally, I accidentally created a second account when I did the samsung account migration (which I am not using), but when I switch over to that, the smartapp adds and works just fine.

I used the api to remove the smartapp as well because it won’t even load on the mobile app. Using classic app.

What am I doing wrong here? Hellllp.


#16

I’d contact support. It’s possible something is still installed that you can’t remove. I’ve had something similar happen with the same SmartApp that prevented me from reinstalling it.