SmartLock: Oh god the notifications!

So, I have a SmartLock on a door in my house. How in gods name do you disable it from notifying you every time the lock is locked or unlocked? Ever since migrating, we’re getting notifications every time…which is insane.

Isn’t there a way to set a ‘normal’ code for the lock or at least turn off the notification every time a guest code is used?

(I’ve tried turning off notifications for the device in a few places in the app…doesn’t stop them.)

Which lock and which smartapp are you using to connect/configure in ST?

It’s a KwikSet Z-Wave Lock. When I migrated to the new app, it looks like everything is just being handled by default device handlers and the stock lock SmartApp (if it’s an app? The SmartLock Guest access item on the main screen, basically.

This is a known… ‘feature’ of Smart Locks Guest Access. If you want the ability to select which codes notify you you can:

  1. Submit a feature request ticket to Samsung (through normal support ticket process) and hope they get enough feedback to change the behavior (search the community - there’s a LOT of us out here who want it changed so that’s not as far fetched as it sounds.
  2. Buy/install/use a third party lock manager smartapp such as RBoy’s Lock User manager either instead of SLGA
  3. turn off all notifications from the locks (probably not desirable)

Personally I don’t use the unlock codes enough for it to bother me, but I highly recommend RBoy’s LUM, well worth the cost for the flexibility. (AND I provided feedback about the need for flexible notifications in SLGA)

1 Like

How would you even turn off all notifications from the locks? I thought I did that and it’s STILL sending me notifications.

Also, won’t third party apps die when the IDE gets shifted/changed?

There is a way in the Hamburger Menu (Top left) > Gear menu (in the hamburger menu Flyout) Notifications. Uncheck the check boxes for the devices you don’t want to send notifications, BUT I highly don’t recommend it because it basically silences the device.

If they’re not updated, yes. But:

  1. that’s about a year out and
  2. that’s one of the, if not the most active / responsive devs in the entire community and their team is already working on updating their custom device handlers to work inside the custom capabilities and presentations that finally started working not even last week. I’m not worried about them NOT updating LUM. That’s why they have my money.

As an aside. The documentation on how to do a new style Smartapp (AWS Lambda / Webhooks) is public - if you have a favorite that you want to see you should be pinging the developers about future plans. IF you’re a dev and have plans - let the community know what they are because as soon as we’re through this migration noise, that’s the next hurdle.

As for the device handlers devs , give them a little time, that documentation on custom actions and presentations is still sketchy and VERY brand new - the VID / custom presentation thing is barely working.

…But the Smartapp devs - yeah absolutely they need to start looking. But again, they have a year, so it’s not hair on fire time yet - but they should at least be thinking about their plans.

And as for Echo Speaks - special case, let tonesto be, he has a lot of hard coding to do in the next 2 weeks.

1 Like

@necromancyr That is simple. Go to SmartThings Settings menu and click on Notifications. Now you can select individually for each device


Thanks to both of you - but this doesn’t work. If you COMPLETELY turn off notifications, it stops - but if you do it ONLY for the lock? Still get notifications.

Mind-numbingly stupid design decision, I have to say, since it means anyone using a code on a smart lock has to get a notification everytime a code is used - or shut off all SmartThings notifications. Or pay someone to address it.

I understand the paying for RBoy’s stuff as an alternative - but really, it’s a smart lock and a basic home automation item, it’s not something crazy or that should require additional support.

1 Like

Just tried and it works on mine app. Turned of Schlage Lock notifications and it worked. Nothing came up on my phone.
However it still shows in history, which is a good thing

Hrm. So…it’s ONLY when the code is used (or the button on the keypad to lock the lock is used) that I get a notification. That may mean it’s coming from the Smart Lock Guest Access SmartApp vs the lock itself.

And there’s no way to turn that notification off, right?

You are correct. Thus my first suggestion… Submit a design change request through a ticket.

Check out this app, you can customize pretty much anything and notifications plus more.

1 Like

Thanks RBoy - I knew your apps were an option and appreciate it. The free single code SmartApp you have may work well to address my need for the short term, with just the stock SmartApp uninstalled. If I was going to use more of your apps/handlers, I’d purchase the broader set but just to get my lock working the price is higher than I’d like (considering I don’t actually need the other features).

But again, thank you - this is a SmartApp issue and you addressed it. :slight_smile: