TUYA devices not showing up in Smartthings

Hi guys

I’ve been doing the smart home stuff for quite some time but have only recently ventured into Smartthings and WebCoRE. The WebCORE part makes sense and I’m enjoying the mental gymnastics.
I’d like to start with a simple question around the integration of TUYA / Smart Life assets into ST. How can I get ALL the TUYA assets into ST? Interestingly all the assets I’ve added to SL since connecting to ST are appearing to ST, although correlation doesn’t imply causation.
Are there known limits with the TUYA integration? Could someone point me in that direction so I can put my mind at rest?

Thanks all

H

Hello,
Did you manage to resolve this?

I’ve been having trouble with Tuya/Smart Life. Admittedly, I have Tuya devices that are not considered “supported” in ST.

When I port them into ST using either the Tuya OR Smart Life integration, it pulls in all the devices over as scenes and I got to control them for about a whole 5 seconds before they all appear offline and then I can’t control them anymore.

While only using the Tuya devices as scenes from the native app isn’t ideal, I can certainly make it work if they’d stay connected.

I DID pull these devices into webcore and when I started programming automations, that’s when I realized they weren’t firing because the devices were not remaining connected.

I have 7 ceiling fans and a humidifier. I tried all of this within the last two weeks.

One thing to note that I think might be causing the issue. Historically, I’ve had all these Tuya devices connected through Alexa. Alexa recognizes the devices somewhat similarly when it comes to showing the devices as “scenes” which always appear as “offline” in Alexa but routines and voice commands ALWAYS seem to work. Alexa also recognizes the fan light and the fan speed as lights (so its a little jenky). You have to tell the fan to be at 50% brightness to change the speed to 50% in automations. By voice, it works every single time in Alexa.

I think the problem is in ST, if the device says it’s offline, ST won’t allow you to force an on command for ANY device. It doesn’t let you do anything (including automations in webcore).

Work is definitely needed to either allow the bypass of initiation commands if a device appears offline, or for tuya/Smart Life to send the devices as actual devices, (not scenes) so they appear online and will accept commands.

I checked to see if maybe we could daisy chain a connection through Simple Commands to Smartthings but it appears to only be a one way connection INTO Simple Commands and I did not see an integration listed in the new ST app for Simple Commands or their other name Kloee.

Simple Commands is very responsive in email.

Tuya, while I’ve never tried, they are a HUGE company and they’re main goal is to grow exponentially. I’m not sure how customer focused they are.

Because the ST integrations say they are not certified in US, I’m sure that’s pretty low on the list of things that Samsung needs to do right now.

I want to follow this thread and see where it goes. Ultimately, I think it’s a setup/configuration issue on the integration itself in ST. If Amazon figured it out, that tells us it’s possible.

I have been using WebCore with my Tuya devices and it works good.
I create separate “on” & “off” scenes in Tuya and I create a virtual switch in Smartthings.
In WebCore the first part of the piston say toggle the “on” scene when the virtual switch is turned “on”. The second part of the piston say toggle the “off” scene when the virtual switch is turned “off”.
I have been using for months with no issues.

Are these plugs and/or bulbs?

Both plugs and bulbs.

I’ve been fussing with this integration some more, and have almost resigned myself to having to do everything via scenes from SL and the IFTTT integration. Tonight, for some reason, one of the scenes appeared in ST, active and on. They always appear with two Chinese characters after the scene name.
Great, I thought, I tested the scene a couple of times and it worked fine - turning off the power to one of my Sonos speakers. Then I thought I’d edit the scene name in ST to remove the two characters. Worked again, for about two minutes and then went offline, never to return. Tried recreating it again but once was apparently enough.

There has to be some logic to why it will work and then doesn’t work. If I can get the scenes to work I can remove the whole IFTTT step, and probably remove the lag in the activations. But no.

I know that both Tuya and SmartThings know why this is happening. Why would they not want to make it work, if only to appear more appealing to their customers? Anyone have some contacts inside these camps?

That’s the exact description of what I’ve encountered. I tried again last night with no progress. I even tried moving some devices from SL to Tuya (because the internet tells me Tuya is more feature rich and the ST app appears to acknowledge more than just bulbs and switches under tuya vs SL). I got the same results.