Smarthings Home Monitor - Ecolink Contact Sensors

I am trying to setup my Ecolink DWZWAVE2-ECO contact sensors. I linked them to my Smarthings Hub V2 and they report battery and contact status. However I cannot set them up in the Home Monitor as a security sensor. During pairing it warned me they did not support all the latest Z-Wave security features. Am I SOL? Is there another device handler that will fix this?

What is the device type in the IDE?

I just tried (titles from IDE Device handlers):
Open/Closed Sensor
ZWave Door/Window Sensor (This is the one Smarthings set it up with - no tamper reports)
ZWave Plus Door/Window Sensor (This is gave me tamper status)

None of the three above allowed me to setup them in the home security monitor

i use this device and it works with STHM. i use the z-wave door/window DTH.

2 Likes

Open/Closed or ZWave Open Closed? I only have the former. Is it local or cloud?

sorry, i corrected my post… door/window

What Hub version do you have? I have V2.

same … v2 …

and it runs local… to answer your question

1 Like

More info from IDE to ensure I correctly ID’d this device

  • MSR: 014A-0004-0002
  • networkSecurityLevel: ZWAVE_LEGACY_NON_SECURE

zw:S type:0701 mfr:014A prod:0004 model:0002 ver:10.01 zwv:4.05 lib:06 cc:5E,86,72,73,80,71,85,59,84,30,70 ccOut:20

This is true, but just refers to “S2 security“ which is a recent Z wave feature that adds additional encryption. It’s not relevant to most people in a typical residential home, and is a lot more important for locks and keypads than it is for open/close sensors.

STHM won’t care one way or the other what security level you are using for your sensors, so that’s not a problem.

So something else is going on with regard to your STHM setup.
can you show us a screenshot of the page where you are trying to set up the sensors in STHM? Also a screenshot of the device details page for the sensor in your app.

It feels a lot more likely that you have the wrong DTH for them and they aren’t showing up as a door sensor at all, but hopefully somebody can figure it out.

For anyone who is interested in the details of S2 security, here they are, but again, they aren’t really relevant for simple open/close sensor unless you were trying to include them in an S2 security group which smartthings can’t do anyway.

any chance that in STHM, you disabled use all sensors and are using selected sensors. in which case, you would need to go in and select them.

1 Like

I am not sure how to disable all sensors - how do I do that? I did go into STHM and toggled on/off/on “Monitor for Intrusions”

open STHM, then click on the cog in the upper right of the screen, click on security, click on set up armed (stay or away) and there is the option to select all sensors or you can disable , if you disable, you can click on that field and individually choose which sensors to use.

don’t worry if you get lost on that… many do

1 Like

OMG that did it. That is a really stupid UI that it doesn’t just tell you to go into settings and include the sensors. Thank you @jkp

2 Likes

All

I have tried and tried but can’t get the camera to record through any automation. See attached automation picture. I do get the sms notification but the camera doesn’t record. Any ideas?