Smarthings andriod app " No network connection..." error after updating to the latest version

My phone is Samsung Note 8 and recently started using Smarthings platform. After updating STs to its latest version, I started experiencing network connection issues. Meanwhile my wife is using Iphone 12 and her samsung smarthings is working fine. I was searching for resolution, people suggested to turn off and on wifi, delete devices, rooms, automation from home screen etc. Nothing resolved the issue. I found somewhere, they suggest to go to → APKS -->latest apks for Smarthings and download any one previous version and try. I am having issues with version I uninstalled current ST and downloaded previous versions and tested them one after the other going back in time. Still same issue, eventually after retro-updating the ST to one year old version which is, network issue has been solved.

The “new” SmartThings app started doing this to me on my Samsung S8 about 7 months ago. I reported it but support was not able to help (it was never resolved). It seemed like it would lose the network change notification when I went from one network (mobile) to my home (WiFi). I found that if I open the app and it reports a bogus “No network connection” I can just toggle airplane mode to get it working again.

(this buggy behavior may have gone away in the “new new” app released this month, but it also might be that I don’t really use it enough anymore to notice)

I havn’t tried Airplane Mode toggling, may be I will try that for next update, if next update is still giving “No network connection” issue. I am done with latest update but thanks for sharing the info.