SmartApp Workflow


(Jody) #1

Today marks the third occasion where I have ran into a major issue with the way SmartApps are handled. I wanted to remove and re-add a device after upgrading it’s firmware. I tried to remove it, but got the warning that it was still associated with some SmartApps. Fair enough. I went through each of the SmartApps and unchecked it, tried removal again, same error message. The only way I was able to remove the device was by uninstalling all of the smart apps that were associated with the device. The completely fried my ubi setup, and the setup to my custom api server. There should be a cleaner way to remove devices than this. Now I have to recreate all of the rules I had used with tasker and Ubi. Please advise if there is an easier way of doing this.


(Edward Pope) #2

Yes,

You go into your various smartapps and deselect the device that you want removed from each one. No need to uninstall.


(Jody) #3

I did that. Several times. The device was not selected in any smart apps and yet I could not remove it until I uninstalled the smart apps.


(Edward Pope) #4

The device had to be selected to be enabled through the smart apps. Can you tell me what type of device you were working with here? I have never had a problem like this.

Was this a personal device where you created?


(Jody) #5

Aeon Multi Sensor. After upgrading the firmware on the first four, I had issues with them connecting. This time I decided to remove the device, upgrade, then re-add the device. I de-selected the device several times in the Ubi smart app, but I could not remove the device until I uninstalled it.


(Edward Pope) #6

You just stated the issue. UBI. I have had this very same issue with UBI, it appears that UBI doesn’t correctly remove the device from itself.

I have seen where it works sometimes as well, I found that if I went to UBI and revoked rights to ST, then re-added only the devices that I wanted, that this will remove the errant device from UBI.

However, the problem is that when you do this, any ST related commands that you have setup with UBI will have to be re-done.