Smartapp is not working

Hi all,

I’ve developed my own app by:

After that, I deploy my automation by

After deployment, my smartapp shows “POST / 200 OK” and “2021-03-21T13:58:01.241Z info: App a00f270e-ad9c-4b7f-b1d2-1cd5e98601f7 callback confirmed”

OK. I’m using the same account in my mobile app and for deploying the automation.

In the mobile app, i go to developer mode.

So, I’m going to “Add SmartApps” in Samsung App, “Add” and my new app is under “CUSTOM”. I select it but after that, it prompts “We are facing problems to connect. Please check the internet connection and try again” (something similar, i’m translating the message).

And thats all. How can i solve that? Thanks

Welcome to the SmartThings Community!
The mobile device where you have the SmartThings app installed is iOS or Android?

Hi @nayelyz
I tried with 2 devices (both are Android): a Galasy A20e with Android 10.0 and a Xiaomi Redmi8 with Android 10Qp1A (in fact, MIUI Global 12.0.4)


Ok, just to clarify:

  • When you finished your SmartApp registration, you received the confirmationURL and used it to verify the app?
  • When you select the SmartApp from the “Custom” list, do you receive an error or the “CONFIGURATION/INITIALIZE” lifecycle request?


  • Yes, i verified the app with the confirmationURL and i used it to verify the app
  • I receive nothing

EDIT: I thing is solved. I re-downloaded the SmartAPP SDK and it’s working now… maybe i changed something and i broke it.

Sorry for the inconvenience