Smart things unable to add codes to Kwikset zwave lock

I have a kwikset 910 that is working normally, but added on a new zwave plus card to my 913. It is connected and able to lock and unlock through both smart things apps, however I can’t get the new lock to update codes. I have tried both the proprietary smart lock guest access and also rboy lock user management. It is set to retry 5 times and eventually times out on retry programming exceeded.

I reset the lock a few times and no luck changing the codes. Any ideas or should I try to get a new zwave card?

hmm, assuming you’ve tried different new batteries and factory reset the lock? Then z wave remove (exclude) then re-add new device? I use the “smart locks” app from the ST marketplace. Dashboard/smart locks/ lock codes/+ Add a lock code is this the step that’s failing?

It could be possible that the module isn’t responding to the programming requests. Since programming locks is a common issue, if you have a Z-Wave repeater lying around try installing one close to your lock and then try to program the codes. If that also fails, try to exclude, hard reset the lock and pair it again.

See this topic for details:

I did a search, and this thread title has my issue, so I’ll put my question in here, although it is a different circumstance.

I have a Kwikset lock that I have been using with Lock Manager and the classic Smartthings app. It has been working. But of course, we need to migrate to the new app, so I did that this weekend.

I migrated the hub, and installed the Guest Access smart app. I can see and control the lock, with one maddening exception. Every time I try to program the cleaner’s code, I get a “something went wrong” error. But only with their code. I was able to program in 4 other codes without an issue. But it seems that whenever I try their code, it fails. It’s the only code that starts with a 6, and it seems I can’t program codes that start with 6, but I can program other ones. This is so bizarre.

Check in the ide that your lock is set as zwave lock with codes. Both kwikset locks I have installed have originally shown up as zwave lock and the lock manager app could not add codes until I changed the setting in the ide.

I’ve tried both types…Z-wave lock, and with codes. Same behavior. Can’t program a code that begins with a 6! Not using Lock Manager anymore, just the Guest Access app.

A couple of quick things, don’t use Z-Wave lock with codes, it actually doesn’t work with any lock management app and is a legacy DTH. The one to use with your Kwikset is “Z-Wave Lock” or this “Enhanced Z-Wave Lock” device handler only.

I believe the issue you’re facing is a quirk of the 910 lock (and similar locks with limited keypads). Basically this lock uses shared buttons due to which it has limited number of “unique” codes which can be programmed. You can find more details the issue documented:

Basically you’ve got another code in the lock which is conflicting with the code you’re trying to program due to lack of unique buttons on the keypad. After reading the articles above you should be able to figure out which of your codes are conflicting based on the keypad layout and there after you should be able to your codes using LUM and the stock device handler without any issues.

Hmm. That’s interesting. But one thing, this is a Kwikset 914. It does have a full keypad. I did try the Universal Enhanced handler as well. Still Isn’t working, but I get a different message. When I try to set up a code that starts with a 6, it spins a bit in the app with the Creating lock code message, and then I get a notification saying “Deleted userxxx from lock xxx.” But the code was never set up in the first place.

When I look at the device information in the IDE screen for the paired lock, its name is “KwikSet SmartCode 910 Contemporary Deadbolt Door Lock” So the 910 must have the same electronics as the 914.