Smart Locks won't show codes


#1

I have a kwikset z-wave and a few months ago the Smart Locks worked fine. I could add or delete codes etc. Now I can see the 5-6 code names I have in there but can’t get it to actually show me the code anymore. I’m trying to confirm a code I put in. Anyone else have this issue?


(Jimmy) #2

Mine doesn’t show to code either, but I can’t remember it ever actually showing it.


(Nathan Curtis) #3

Nor would I want it to in that part of the interface, it’s kind of a security issue on shared locations. But then again the whole security model of shared locations are broken, so I won’t beat that dead equine animal.


(www.rboyapps.com - Make your home your butler!) #4

SmartLocks has never shown codes from the beginning. You can only add/remove and you will need to remember the codes.

If you want to see the codes then you’ll have a separate external SmartApp like Lock User Manager which shows you the codes and also allows you to update them. It also synchronizes the users/codes with SmartLocks, i.e. any codes you enter in Lock User Manager will show up in SmartLocks - but don’t do it the other way round as SmartLocks doesn’t report the codes to other apps.

If you don’t want to use an external SmartApp, there is one trick you can use to “see” the current codes, open your My Device page in the IDE, click on your lock and you can see the raw data saved by the device handler which will show you lock codes.


(Brad) #5

I don’t believe that’s true. Lock codes shouldn’t be displayed anywhere within SmartThings.