Smart Lock Guest Access - "Couldn't download"?

I’ve been using Smart Lock Guest Access in the new SmartThings app for a couple of months now and have been having an issue with it lately. I can no longer Lock and unlock my deadbolt from the app (Schlage Z-Wave Plus). In addition, when I tap on its heading or anywhere in the tile other than the Lock/Unlock all button it gives me a pop-up message saying “Couldn’t download Smart Lock Guest Access”. Try again.". I believe that it used to show me the status of the Lock (online, offline, etc) when I tapped it. You can see the message at the bottom of the attached screenshot.
Oddly, when the lock is manually toggled I still get the notifications for it.

I don’t see a way to remove the Smart Lock feature so that I can re-add it. I so have the deadbolt set up in the old app with “Smart Locks” and it’s not working there either. The only thing that has changed is that my phone updated to Android 10. Could that have something to do with it?

Any ideas? TIA!

Edit: Using the SmartThings v3 hub.


Try to uninstall it and reinstall it from the Automations page, click on the 3 dots and delete.

Alternatively if you have access to RBoy Apps, you can try LUM: [RELEASE] Lock User Management - Door lock code manager (create, delete and schedule codes) with automatic lock/unlock, custom user actions and SHM/ADT integration (LUM)

1 Like

Thanks for the tip. I tried that and it still gives the error. :confused:

Looks like I may have to check out the Rboy stuff!

i’m betting on android 10. There are some known bugs with the SmartThings app and Android 10.


Got the below response to my message to SmartThings support, confirming that it’s an Android 10-related issue:

Dear Samsung Customer,

Thank you for contacting Samsung SmartThings Support.

We are deeply sorry you are experiencing issues with SmartThings. This is related to an issue on our end for Android 10 and we are working hard to resolve this. We thank you for your patience.

If you have any other questions or concerns, please feel free to contact us.

Best regards
Samsung SmartThings Support.

1 Like

Same issue. Pixel 3/Android 10. Select the Lock App and receive ‘Couldn’t download Smart LockGuesy Access’. Removed app and reinstalled, same issue. Automation for that app is currently broken. I’m interested in when they fix it.

Yes, this needs a fix for Android 10. I’m going on vacation and need to add a guest code. This is an important function of the lock


I was able to add and delete codes via the classic app. The name assigned for the code doesn’t show up in the notifications, but at least I can add a code for now if needed until they fix the new app.

1 Like

Ok, so I added this and it shows up in both the classic and new app. I have the smart locks app installed, but when I click on it it basically just asks to confirm the location and the locks. In the “history” section it says it updated two codes for the 2 locks I have installed. For the life of me I can’t see where to change the code(s) in either the new or classic app?

In the new app, go into it and tap Locks drop down in the upper left.

In the old app, if see your “smart locks” in the “Home Solutions” card, click that. The tab labeled “Lock Codes” allows you to add a code.

Still no dice in the new app. I see there was a notification today about the update breaking things and Samsung phones are getting a hot fix.

1 Like

Are you using a custom device handler? This happened to me as well [still on Android Pie]. Once I switched back to the stock device handler, i was able to install. Then went back to custom device handler and it worked perfectly.

1 Like

Not sure I know what you mean by device handler… I just installed and set it up. Didn’t install anything extra as far as I know. How could I check?
Then click “My Devices”; under type the stock device handler is “Z-Wave Lock”.

I have the same issue with my Pixel.

I haven’t seen a good response from SmartThings yet on this issue. It is clearly an Android 10 incompatibility issue. It would be good to at least get a acknowledgment of the issue and that they are working on it.


Hi Tabe - I had the same problem. After reading through this thread, I saw that other contributors mentioned that this problem was happening specifically with the Google Pixel 3 running Android 10. Since that is my phone and operating system, I figured that was my problem. So, I installed the new SmartThings app on my Samsung 5E tablet which runs Android 9 and it works perfectly. So, thanks to the community for helping me solve this problem. Tabe - if you have a tablet or other device that you can use to run the App that might be a good workaround for you too until the conflict between Pixel 3/ Android 10/ SmartThings is resolved. Its not ideal but its better than not being able to access this feature at all.


Ah, I went to enable the Pet Sitters lock Code, which I was previously able to disable… I can not access the lock codes on my PH-1 Android 10… so, put the App on my wifes old Nesus 5… I was able to see the codes… no option to enable/disable them like we used to have. Apparently, to disable… you have to delete now?

I wish they would get this fixed… never fails… that it fails me right when we need it… (pets and time away from home)

Yeah, the work around I’ve been using is in the old app - I delete codes to “disable” them. I add a code with a generic name, then rename the code to something useful after it has been added to the lock.

I also wish they’d get it fixed in the new app. At least the function is still there, but you have to really work around alot of hassle.

1 Like

Happy to have just found this thread, also experiencing same issue on Pixel 3 with Android 10. Please put out a fix for the newer version of the app!

I can’t believe that this is still an issue. I saw that the app was updated in 11/6 and was hopeful that it had been resolved. Nope! :confused: