Smart Lighting Automations Not Working Recently

Recently over the past 4-5 days I’ve noticed that a lot of my Smart Lighting automations haven’t been working properly. For example, I have one set to turn on my Front Porch light at sunset and another to turn it off at sunrise. The last couple of nights, it has not turned on at sunset and I’ve had to manually turn it on. Another is to have driveway lights to turn on when the garage is opened after sunset. This automation also has not been working lately.

The best I can figure out is that this has to do with sunrise/sunset automations, but I haven’t done extensive testing. Just a best guess based on what’s happening. Is anyone else having issues lately?

my sunset/sunrise automations are still working. maybe try deleting and re automating them.

I’ve been having this issue for a while now. Was using Hue lights for the sunrise/sunset routine… stopped working a while ago. I thought maybe it had something to do with the Hue lights, so today I switched to SmartThings Bulbs. In doing so it deleted my existing automations associated with them, and had to recreate them for the new bulbs. Still not working. I’ve logged into my hub via IDE and made sure that sunset and sunrise times were correct. They are. Not sure what else to do… Using a V2 hub if that matters…

You might consider running automations via tools outside of ST. Wherever possible, I use webCore and Sharptools Rule engine. For example, I run everything that turns a light on or off via some schedule via Rule Engine. I works well as you can use delays to stagger actions.


When I used to use smart lighting I would need to login to the ide and refresh each instance of it or, delete and rebuild in the app.

Since then I’ve moved to another platform that runs webcore locally. No issues since moving lighting automations to webcore.

Unfortunately webcore on smartthings runs in the cloud so you may notice a longer delay with automations and, any internet outages will stop everything.

Having this issue as well. I’m moving all of my SmartLighting rules (that worked flawlessly for years but are now acting up!:face_with_symbols_over_mouth:) over to webCoRE.

Actually, I’m moving everything over to webCoRE, back all the Pistons up, and wait for the sh$t show finale. If things go further South, I’m out. Already have an alternative hub that can host all the webCoRE Pistons.

I just got finished setting up webcore but when I go to my dashboard it says “There was a problem loading your devices. The data shown below may be outdated; please refresh the page and try again.”. My page is blank. I’ve checked over on the webcore (forums?) and any solutions that have been suggested there won’t work…

1st item to check…

Did you install all 4 Smartapps in IDE at and published all 4.


Sometimes it is best to start fresh again. Remove all the items you installed in IDE and start again. Follow the instructions again to make sure everything is set up properly.

There is a community installer smartapp you can install and use it to install webcore for you.

I followed these instructions… it only seems to be for 1 instead of 4? What am I missing?

Ahhh, don’t follow those instructions. They did not even post the correct link for IDE.

Follow these instructions from the webcore wiki page…

When you get to the section for setting up in the Classic app, go to this link for setting up in the new app:

Got it, thanks for that. The only thing I needed to do was add the 3other 3 components and update… It’s working now… now to figure out how to do something based on sunrise/sunset…

1 Like

Remember that you can always ask questions on building pistons on the webcore community forum. There are several users who enjoy helping others build their pistons. Plus there are lots of example pistons you can look at to get started :slight_smile:

Here is a sample . . turns a light on at sunset and off a bit before sunrise