Smart Apps - cannot add new routine to an existing SmartApp

I am trying to add a routine to a blind automation in the SmartApps in the new smarthings app.
When I try to create a a new routine for this blind automation I get the error message “there is an error, please try and install the SmartApp again”.
I am at a loss at what do to. Any help would be very welcome.
Thank you


You are trying to edit an existing automation and add a new action to it?

Yes. Correct. I also tried to the same in the classic app but no luck there either

When you say Routine, do you mean SmartApp ? Routines were discontinued with the Classic app.

If you’re using a SmartApp, it could be one of 2 reasons:

  1. The platform is overloaded due to maintenance/other reasons. This is typical on a Sunday evening or Monday morning. Take a screenshots and report it to and then try after a while
  2. The SmartApp has an issue (if it was working earlier but not now then it’s likely 1 above), is it’s a custom SmartApp which one is it?

Yes. I mean a smartapp. The app is a blind automation, one command disappeared. I tried to fix it by creating creating a replacement blind automation, but I crashed out of the automation all the time.

I need to try if it works now. If not I do as you suggest.

Thank you. Monika