Slow dimmer in theater room


#1

Is there a smart app that will allow my dimmer to slowly go to a certain percentage. I purchased 2 GE Zwave dimmers. Right now they almost act like switches. I have a routine called movie Time that puts dimmers to 10%. I also have a motion sensor that turns my dimmers on full. I would like both situations to happen over 10 seconds instead of immediately.


[RELEASE] PlexPlus - Control Lighting with Plex Play Status
[RELEASE] Fibaro Dimmer 2 (FGD-212) - Advanced DTH (V2)
#2

In the Marketplace under Lights & switches section, look for “Gentle Wake Up”. It says it’s bringing the lights up, but I use it to dim. I renamed it “Dim It” in my app. I have it set to dim from the current level down to 1% over a period of 30 minutes. You can set it up however you need it. Works great from movie time.


(Ben W) #3

There is also this device handler that allows you to adjust Dimmer ramp rates in GE dimmers:

You increase the time between steps to get it up to the 10 seconds.


#4

The device handler worked. I have no idea what github is. I followed your document, added your code and I got it to work. That is exactly what I wanted. How do I learn what I did and add more device handlers?

Thanks


#5

I appreciate the attempt. I needed it to be faster. The device handler is a better option for me.


(Ben W) #6

I would recommend native device handlers, I plan to submit this once ST stabilizes for a bit. I just realized I missed a step, you need to change the default device handler for the switch to this one, then you will have all the goodness.

Github is just a site people can share and collaborate on code. There are ton of custom handlers and smart apps. search the forum for nearly anything (Garage Door? Check, Nest? Check)


#7

Ok everything worked with the device handler with my motion sensor and dimmers. But I made two routines movie Time and end Movie Time and it does not seem to slowly dim during those situations. Is there a tweak I need to do?


(Ben W) #8

The device handler sends programs the switch with the step amounts. My guess is that the routine you have sets it to 80% which is executed immediately. In that case Gentle Wake up may work better.


#9

i just tried this with my GE dimmer switch and still no luck dimming slowly…

i get the enhanced options but doesnt seem to do anything.


#10

Did you make a github account and copy the device handler info into your SMART hub? It works for me.


#11

i installed using “With GitHub Integration”


#12

Can someone suggest some settings to try to slow the dimming? Here is what I have set currently and I don’t see and dimming change from the default device handler.