Simulator doesn't run


(Brent Kenreich) #1

is anyone else having issues with the simulator? I tried three different computers and every browser I could think of: IE9, IE10, Chrome, Firefox, and Safari. Even using a default app the simulation buttons don’t work. I can’t get the virtual switches to change state even using the play button underneath them. This does work from my iPhone…not that I want to write code on my phone. Has anyone else experienced this?


(Christopher Blickley) #2

Did you ever resolve this? I have the same issue…none of the virtual devices respond in the simulator and there is no output to the console.


(lkiarest) #3

I have the same problem~~
And I’m using Firefox 32.0.2


(Christopher Blickley) #4

I eventually figured out that the simulator was relying on port 8443. I had to make an exception in my firewall.


(Brent Kenreich) #5

Definitely not my problem. I’m not blocking any outgoing ports.

FWIW I passed the CCIE written exam…I also got so frustrated with Smartthings apps not working, “working” out of the mode, automated tasks working 1 day and not the next, lights spontaneously turning themselves on…I haven’t bothered to try the simulator in months.

I hope Samsung will improve on things…although since my IoT Samsung washer speaks broken English, forces me to push a button to enable the washer to be controlled via the mobile app every cycle, looses my logon, the washer disappears from the app regularly, I’m not hopeful


(lkiarest) #6

In my firefox I can see an http error when start simulator:
Firefox can’t connect to wss://ic.connect.smartthings.com:8443/device/virtual-e7e768d5-842d-4ee6-9835-6cffb17432b8.
I have tried to use a http proxy, but it still can’t connect to that address.


(John Fisher) #7

I’ve noticed the simulator doesn’t run if I’ve got an open vpn connection to the network at my work. I get the same error as above: can’t connect to ic.connect.smartthings.com:8443.

Once I close the vpn connection, the simulator will run as expected.

Oddly, the simulator works if I’m at my desktop at work (I’ve got two hubs, one at home & one at work). We must have an extra rule for vpn that blocks port 8443 … don’t really know, I’m not a networking guy.


(David Maltby) #8

Thanks! I had a VPN connection open and had the same issue. Needed to close the VPN connection and reopen the page in a new browser instance though.


(Chen Adrian) #9

Im guessing non of this is mentioned in the docs…