Simulated Thermostat (Celsius)

I am using a simulated thermostat.

The setting of my hub is intended to use Celsius, but the simulated thermostat is displayed in degrees Fahrenheit.

I’d like to see the simulated thermostat in Celsius. Is there anything else I can do?

I looked a few months ago and didnt find one. I think you’d have to edit the code yourself…I just gave up in the end.

Kraeg

Where can I find the current simulated thermostat’s DTH?

I could not find the simulated thermostat with the default function.

SmartThings Public GitHub…

@tgauchat

I solved the problem.

Thank you for helping me.

1 Like

What did you do to fix it?

Id like to know how you fixed it too. When posting on these communities its important to remember that you are part of the solution too, post what worked so others get use from it, not just you.

+1 for the fix :slight_smile: I noticed that when I changed heating / cooling setpoints it changes to C but the actual temperature is still at F but at some point it goes back to F so it is buggy.

PS: I made a Celsius version of the DH. It is my first one so I hope I have not broken anything. I am testing it at home but if you guys want to test it feel free to get it from here:
Simulated Thermostat Celsius