SHM Stuck on "Clip Generating" with Arlo Camera's

arlo
smartthings
shm
smarthomemonitor
cameras

(James) #1

Hello All

I’ve just connected an Arlo camera to my ST

I programmed Smart Home Monitor to record a video clip when there is an intruder. But when I triggered an intruder Alert the video clip is stuck on “Clip Generating”.

Also to note… it seems that the smart home monitor doesn’t even send a message to the arlo camera to start recording as the IR lights didn’t even come on (it was dark).

However I know smartthings can communicate with the camera as when I get a live feed the camera activates and shows the live feed.

Anyone got any ideas what’s wrong or having the same issue with any way to fix it. I was on chat with support for hours and they’ve had no joy so far…

Many thanks

J


Arlo SHM generates no clips
(Ryan Little) #2

I have the same issue on Custom. For me it happens when the camera DOESNT detect motion but is triggered by another camera to record. I also don’t get video in the Arlo app tho.


(Bobby) #3

Can you create a custom SHM instance to see if it records? I only use custom instances and my cams record. I do see a little bug, if I pick a different motion sensor along with the cam’s motion, I get two entries, as if the cam tried to record two clips at the same time, but only one is generated. Tagging @twack to see if he has any ideas for your problems…


(Ryan Little) #4

Mine this morning. The driveway cam was actually the one that detected motion (the sun) as the camera on my house doesn’t trigger the driveway, only the driveway triggers the house cam.


(James) #5

Hey All

So I’ve tried various motion sensors and its the same problem will all of them. The Clip is stuck on generating.

I’ve also tried a custom SHM instance, and again the clip is still stuck on generating.

There is no recording in my Arlo app library either.

The Arlo is in SmartThings mode to, so I’m completely baffled.

Any more ideas?

Thanks, J


(James) #6

Hello All

So I found the fix after much research and testing.

Basically, it seems that Arlo doesn’t always set the time zone of the base station when its set up. If it doesn’t, then it wont download the latest firmware (which enables smartthings support).

Therefore, the fix is fairly straight forward:

  • Completely remove the SmartThings mode from Arlo.

  • Remove Arlo completely from SmartThings

  • Change the time zone of the Arlo base station to your time zone. (Found in settings > base station > time zone in the Arlo app / web page)

  • Reboot the Arlo base station (it may show an update is available prior to reboot so this step may not be needed)

  • Download the latest firmware for the base station. (I found that my base station automatically downloaded the update and installed it whilst rebooting).

  • Download the latest firmware for your cameras.

Then reconnect your Arlo cameras to SmartThings and hay presto… it works! (after setting up of the SHM etc)

J


#7

My firmware is 1.4.2695 time zone was set correctly before I added it to st. I can view live streams but when it detects motion the st just shows the generating icon. It doesn’t trigger the record function.