Shelly Qubino Wave 1PM vs. SmartThings hub v3 compatibility

Hi SmartThings community,

When trying to include an Shelly Qubino Wave 1PM with the QR DSK code, the SmartThings can´t find the Wave 1PM and gives error code 34-302. The SmartThings hub v3 & Wave 1PM is approx. 20-30cm from each others.

https://www.shelly.com/en/products/shop/shelly-qubino--wave-1-pm

When I tried manual inclusion with the S-button on the Shellly Qubino Wave device, and put the Wave 1PM into manual inclusion mode, and scanned for nerby devices in SmartThings. Then after second try, it worked and got added.

When the inclusion was finished, I got this message in SmartThings. That dosen´t sound to good…


Some security features not supported

Your device is now connected, but it dosen´t support latest Z-Wave security standards. It´s still safe to use the device for most ordinary use cases, but it´s not recomended for use in sensitive locations or situations.


I could after that give the Wave 1PM an name and place it into a room. But after that, the Wave 1PM went offline in SmartThings. The Wave 1PM is blinking green, 0.1s/2s. so the status looked okay. After some troubleshooting, I did an “Repair Z-Wave network” in SmartThings and then the Wave 1PM got online in SmartThings. Then it was possible to switch on & off. But the Power Metering and Energy Consumption are missing.

So, should the Shelly Qubino Wave 1PM work with S2 QR DSK code inclusion in SmartThings? Or is it like that the compatibility level is not so good and the statement “Compatible with all certified Z-Wave devices and gateways available in the market” isn´t correct for SmartThings hub v3?

Or just me that have some local trouble?

Thank you in advance!

If you have the newest version, it says it supports S2 security. Perhaps when you tried to add it the first time, the device was still associated with a different Z-Wave network due to testing. I would suggest doing a Z-Wave exclude on the device and re-add it using the QR code. Also, you can check the Network Security Level using either the ST CLI or the community developed API Browser+.

As for the power metering and energy consumption being missing, it could be that you need a different Edge driver to expose those capabilities. I’d check out this topic regarding Shellly devices and Edge drivers.

Hi and thanks for your response,

I have been in contact with Shelly Support. They say that they are waiting for response from SmartThings to be able to certifie their new Z-wave devices for SmartThings.

As I understand it, SmartThings dosen´t follw the z-wave standard and procedures to 100%. (my interpretion)

Shelly have developed SmartThings drivers and are ready, so if only SmartThings will respond to Shelly, they will start the certification process.

In meantime Shelly also have the workarund with edge drivers availeble, that I got access to, logged in, enrolled and installed. After that it was possibe to do an manual Shelly S-button inclusion and during the inclusion process I had to scan the QR code due to security.

Anyhow, now the Shelly Wave 1PM shows up in SmartThings and I can control the on-off and it has Power metering and Energy consumption.

1 Like

To my mind, as a network engineer, what smartthings does is very annoying. But they’ve always done it the same way.

They do follow the Z wave standard (that’s how they get their own devices certified), but then to use the smartthings app You have to also follow their own proprietary architecture layer, which they put on top of the independent third-party standard for both Z wave and Zigbee. And that’s where things start to break down.

Device manufacturers who already spent time and money meeting the independent third-party standard usually don’t want to invest in something that’s specific only to Smartthings. A few of the smaller companies like Zooz and Inovelli do make that extra effort, but most of the bigger companies don’t.

So you end up with a device which is certified for Z wave and a smartthings hub which is certified for Z wave and you still can’t add your device. Makes me crazy. :rage:

If the device itself is popular, there will usually be a community developer who will create a custom edge Driver for it, so that it can work with the smartthings platform. But then not only are you, depending on the community, smartthings support usually won’t help you if you run into a problem because you’re using custom code.

It sounds like you’ve got the problem solved for this particular device since the manufacture created their own custom edge Driver.

In case you run into this within future Z wave devices, The community is very helpful and very creative and you can request that a community developer create a custom edge Driver, and that may or may not happen. But the official channels can be very frustrating.

If you’re interested in asking the community developers, you can do so in the following thread. Read the first post carefully so you know what information you have to include in your request so that the developers can help you.

Post Requests for Zwave Edge Drivers Here (community-created)

1 Like

@JDRoberts Thank you for the detailed explanation!

1 Like

Hi,
How can you publish this edge driver?
I need it as well

Here´s the url to the Shelly Qubino Wave Edge drivers.

The new invite url:
https://bestow-regional.api.smartthings.com/invite/adMKvAPaArj9

The old invitre url:
https://bestow-regional.api.smartthings.com/invite/KPMeEpGzx5MQ

1 Like

How can I get invitation to this url. When I click this link I get the message “forbidden access”
Samsung account

yes, me too.

Hi,

I also get the “You do not have permission” message.
Since it was Shellys own Edge driver invitation URL I got and that was okay to share, I suppose they have blocked or removed it, if it dosen´t work anymore. Maybe thay have a new URL? Or new updated Edge drivers on its way? Or that the native Shelly Wave SmartThings drivers are certified and (soon) ready?

So I suppose you have to do as I did to get the Edge driver URL. Create a service ticket att Shelly Support.

1 Like

Here are the new invitation url to Shelly Qubino Wave Edge drivers.

https://bestow-regional.api.smartthings.com/invite/adMKvAPaArj9

2 Likes