Sharptools Widget to Increase/Decrease Temperature By One

I had 4 Sharptool widgets setup which when pressed will change the temperature by one degree. For example, if I tap the “heat+” widget, it will increase the heating setpoint by one. At some point, they stopped working. Now when I tap on them, it gives a “server side error (500)” toast message. I can’t figure out how I configured the widgets last time.

Please give me your suggestions on how to setup widgets to change the thermostat temperature.


If you still have the widgets setup, you can try re-authorizing your things from the SharpTools settings. If it’s an authorization issue that’s causing the 500 error, this should fix it. (Otherwise we may need to watch the Live Logs while you tap the widget).

Tap the menu button and select Settings, then select ‘Authorize Things’ and follow the prompts

Once you’ve re-authorized your things, if your widgets still aren’t working, you can try removing them from your homescreen (it varies by homescreen/manufacturer, but typically you long press on the widget and drag it to a trash can). And you can setup the widgets again typically by long-pressing on your homescreen and selecting from the list of widgets (again, it varies by manufacturer) .

1 Like

I still have the widgets setup. Some of the widgets (such as thermostat on/off) are working without issues. Only those that change temperature has issue. I also tried reauthorizing, still getting the same error.

I should have made my question bit more clear. I apologize for that. What I am trying to do is this - add a widget which on tapping will increase the thermostat temperature by one degree. I can’t figure out what to use in the parameters field to achieve this (referring to the screenshot above).

Try using the heatLevelUp and heatLevelDown command instead of the setheatingsetpoint command.

1 Like

Mine doesn’t have those two. The only ones available are setHeating/CoolingSetPoint & quickSetCool/Heat.

Did you subscribe to everything for the thermostat in the sharptools app?

Do you have Tasker? Is it possible you set the widget up with Tasker? Or could your device type changed - as Ernie notes, different device types have different commands available and some might have an up/down option like Ernie mentioned.

Using Tasker, you could create a widget that grabs the current temperature setpoint, adds 1 degree to it, and then calls one of the set temperature commands with that new temperature.

Alternatively, you could setup a few widgets with your favorite setpoints (or even setup a Tasker widget that opens a menu showing an couple of temperature options).

The parameters field in your screenshot requires a numeric value (eg. 76 to set the temperature to 76 degrees)

When used in Tasker, you can hit the tag icon that shows up in the action bar which allows you to enter Tasker variables for the parameters.

For some reason I assumed @unni was using Tasker. Sorry about that. I use a CT100 and the heatLevelUp and heatLevelDown show up for the thermostat in Tasker when using the “My CT100 Thermostat” device type.


Thanks for the clarification. I wonder if you guys are using different device types… The same methods should show in Tasker and the widgets.

I would hazard a guess that the My CT100 Thermostat is a custom device type with those methods.

1 Like

When I added the widgets last time, I was using the ‘My CT100 device type’. Some time back, it was giving some problems with routines, so I changed back to ST official device type for CT100. I just tried changing to the ‘My CT100’ one. Now SharpTools widget configuration shows the up/down parameters @ErnieG mentioned. Thanks both of you. I spend at least an hour trying to figure out before posting here.