Setting Mode to Day with Automations

This is such a silly posting that I can’t believe it isn’t a trivial solution so where am I going wrong.

I can set the Mode of SmartThings to “Home”,”Away” or “Night” with the Action section of Automations but once I have set the Mode to Night there is no option to set it back to Day in my menu.

Is there a setting somewhere that gives me that option or am I completely missing the point somewhere.? Many thanks.

you can only set the location mode once per automation. you would need a second automation to set it to day.

there is also the ability to manually set location mode in dashboard > 3 dots in the upper right of screen > manage location

And if you’re referring to having the ability to set a Location Mode to ‘Day’ you’ll have to create a custom Location Mode called ‘Day’ in the IDE before it will appear.

1 Like

Thanks very much. All this shows is that I’m very new to this. I didn’t know there was an IDE. I’ll go and research it. That sounds like fun. Rgds

Now that is the focus of my issue.

If I go into Manage Location>Mode I am presented with three Options only:
Away and

There is no Day Option.Same if I am creating an automation. No Day option in Actions.

This seem weird and feels like it should be impossible. Anything obvious that would give this phenomena. . Many thanks.

1 Like

When you set up a new account with smartthings, there are three default modes:

So home and day are essentially the same thing.

When you go into the IDE, in the place where the modes are listed there is an option to add additional custom modes, so you could add “day” there if you wanted to. At our house we have added a custom mode for “guest.”

After that, you have to wait about 10 minutes and then your custom mode will show up on the mode lists when you are creating an automation and you can select it just like you would any of the default modes. :sunglasses:


Wonderful answer and thanks very much. Equating Home with Day seems illogical, I mean it could be day and I was away, but the IDE solutions seems to add the flexibility. I will look at the IDE, which I never knew existed.

A whole new sandpit of toys.

Rgds and Thanks. I’m not mad after all. (Well I may be but that’s different…)


Thanks for your reply. I put it in the wrong place though, so in case you didn’t see it, much appreciated.

Snag… (Of course) Does the IDE work with Aeotec Hub V3? I can get into the IDE but it doesn’t see my Aeotec hub. Aeotec seems to be the default hub now and apparently identical to the Samsung one so one might hope it would work.

Make sure you are accessing the IDE as as older documentation refers to it as With the latter you need to click on your location name in the opening screen to be taken to the correct place, using will take you straight there.

1 Like

Hooray. It worked. Enormous thanks. Dragged me out of my WTF pit.

1 Like