Set Scenes to Local?

Is there a way to set Scenes to operate locally in the new App? I’ve confirmed that all devices in the scenes are local but it seems that there is no way to make them process locally.

No - but the scene is just a collection of devices triggered through the app or a voice assistant anyway, so without the Internet for the App or the UI to be able to talk to the hub, they’re useless anyway.

What are you actually trying to do? There may be ways to make it local.


or an automation. Either way, still requires internet.

1 Like

SmartLighting can activate a scene, so that might potentially be local, Assuming, of course, that all of the included devices were local.

I don’t know how useful it would be, but it might be possible.

1 Like

I’m having some trouble just the last few days with my Automations not actually performing the whole list of actions. One being the scenes, I thought if perhaps it was local they would be more reliable.

I was working under the assumption that if the “scene” (the collection of local devices) was cloud based that I was better off individually firing those devices locally in my smartlighting app?

FWIW The scenes will all perform their duties just fine if I click them in the app, it’s really an Automations problem I’m having recently.

  1. Sorry, with an automation trigger, no - that requires the cloud at the present time…
  2. the platform itself has been having some trouble the last few days (see outage notifications from the weekend) and I’d guess probably the source of your frustrations, but it could be a hundred reasons why.
  3. Less likely - I’d suspect you were already having issues before this week - how many devices total? There were some ‘guardrails’ applied to activities which in essence amounted to throttling the number of actions that could chain to one single automation.

I’d go with JD’s suggestion, actually - Use SmartLighting when a lighting automation absolutely has to run local. If the cloud is at fault then that will clear the issue for sure - but as he points out ALL devices in the SmartLighting rule must be local for it to run properly.


#2 - I’m hoping you are right, I saw the outage notification but I thought it said resolved? I submitted a support ticket but given the generic advice I was digging for other possibilities.

#3 - I read about a 250 action limit, I’ve only got about 30 devices total in my home, at the present my automations have at most 5 or 6 “thens” (I realize each of those could result in more actions) so I can’t believe I’m at the limit.

These were working but I have been having to tinker with it regularly since I did the app transition a couple of months ago. I’d gotten the email to migrate but due to any number of [likely self caused] glitches I had quite a time making the transition. Mostly I had to wipe out everything and start over, even needing to go to the IDE and delete some latent old app behaviors that weren’t [new]app accessible but were misbehaving anyway.

I haven’t tested it, but this may work depending on the actions the scene is taking. reviewing mine, it looks like basic on/off and maybe dim settings can run local (if the device is local), but color changes do not (far right column is local state)


So revised:
Smartlighting MAY be able to trigger a SmartThings scene and run local IF:
all devices are local
No device is performing a color change events
The user is not a fan of the Denver Broncos… (Don’t worry, that’s a very small subset of people - it likely won’t affect you.)



There are several other conditions, too, all of which have to do with features that are run through the smartthings cloud.

For example, the SmartLighting Automation can’t include or be filtered by mode changes. Or Geopresence.

1 Like