Set Cool / Heat From Routine


(David Shellberg) #1

I am using a Nest Thermostat and have my Routines set the temperature. This has been working without issue through the winter. Not that it is warmer out and we are using the AC I noticed that the Routines are not setting the Cool temp. I tried deleting and adding the thermostat tried creating a new routine. If I have the routine set with both the cool and heat temp only the heat works. If I remove the heat setting then cool starts to work. Anyone have any ideas to get this working properly so I don’t have to edit my routines every time I change the thermostat from Heat to Cool?


(fightingmajor) #2

Remove your heat setting in the routine.


(Ben W) #3

What are using to control your Nest (Nest-Manager?)

Ran though the test scenario and cool sets correctly for me when I run my good bye routine.


(David Shellberg) #4

Hello desertblade, I am using the code from Author: "dianoga7@3dgo.net, Code: https://github.com/smartthings-users/device-type.nest".

What is Nest-Manger, do you have any information on where to get it?

Thanks for your help.


(Ben W) #5

Here you go!


(David Shellberg) #6

Thank you this Nest app is so much better. It even pulls in my 6 Protects. This also fixes my routine and cool settings.


(Ben W) #7

I like the easy fixes.