Sengled Smart Switch buttons not doing anything

First time using a Sengled device. It connected to ST as easy as anything else. I can see it in my list of devices.
I attempted to create Smart Lighting with Mirror Behavior, Turn on, or Turn off with another light switch in ST. I even attempted to create an automation to control the light switch. Neither of these worked.
Then I noticed while looking at the device in ST and pressing the on/off buttons nothing happened in the app. If I turned it On or Off in the app then the “Mirror Behavior” actually worked. So I’m very confused why the buttons on the Smart Switch remote aren’t actually doing anything.

Any help would be appreciated, thanks.

What I’m trying to do:
We have a light switch on the far end of a room to control one set of lights (connected to ST) and I don’t want to have to walk back to turn the lights off. Sounds lazy when I hear myself say it but it’s more of a marriage saver … my wife never turns those off because the switch is too far.

If this was earlier today and you are in the Americas, there was an incident affecting passing device events for Hub-connected devices to the cloud.

Otherwise, if this has been a longer standing issue with the device I would delete, reset, and re-join it to the Hub. Not sure what the Zigbee terminology is for the equivalent functionality, but for Z-Wave, this would sound like the device is not properly associated to the lifeline group of the Hub (how events get from the device → Hub correctly, this happens upon enrollment).

Hopefully this is helpful. Screenshots of the Automation/Smart Lighting items, as well as how the device appears in the IDE would be helpful for further review.

Yes it was today only. So I bought this, it was delivered, and the one day that I try to connect it there’s an “incident”??? Ugh, figures.
Is there an update needed for it to work? Last time I tried was about an hour ago.

Thanks @garrett.kranz

There shouldn’t be an update needed, no. Make sure button presses, on/off, etc. events generated by you physically clicking on the device are making it to the device’s event history using the App or IDE.

If you have additional troubles with it, I’d try the delete, reset, and re-join I mentioned. I’m not sure what would’ve happened if you paired this up while the incident was active, but it could have had some adverse effects.

1 Like

Association groups, including the lifeline group, are zwave constructs that are not used in zigbee.

In Zigbee, Devices “check in“ on a regular time schedule. You can’t mess that up the way you can With zwave associations. It just automatically happens with every device that joins the network.

Zigbee is significantly better than Z wave at power management, and the architecture design is very sensitive to Power usage, so it has a quite sophisticated polling structure to help extend battery life.

The following is a very technical article, but I thought you might be interested. :sunglasses: Note the “long polling“ and “short polling“ constructs, which are not available in zwave.

https://www.qorvo.com/design-hub/blog/demystifying-polling-control-in-zigbee-networks

So the short answer is that the whole “lifeline/check in“ design is quite different between zwave and zigbee.

2 Likes

I wrote that sentence secretly hoping you’d pop in to school me on the matter, thank you @JDRoberts :slight_smile:

2 Likes

There are two separate issues that need to be discussed regarding this specific device.

(First rule of home automation: the model number matters.)

The first is that Sengled devices take a little longer for those zigbee checkins I just mentioned than some other brands and they tend to disconnect from the network fairly often because of that.

The manufacturer’s solution to this is to recommend that you set your smartthings account to allow “insecure re-join.“ this allows devices that have been disconnected from the network to re-join without needing the security key. Which is exactly as scary as it sounds. :exploding_head: It’s not a good idea, it’s not recommended, but on the other hand, these are lightbulbs, so do you really care if somebody asks your network to add an extra one?

Which has a really really really long answer which can be summarized as: theoretically, there are a few people that should care, like nuclear power plants or banks or Mark Cuban‘s house, but honestly, most of the time in general there’s no practical target for a hacker, they have to be close to your house for quite a long time, be very patient, and have some reason for why they think adding another lightbulb might be useful. All of which is why smartthings still allows you to turn off secure rejoin. And which is why manufacturers like Sengled can get away with recommending that you do so without putting a lot of black box warnings around that recommendation. :thinking:

But understand that once you do that you are doing it for your entire zigbee network. Not just one specific device. It’s like leaving a second story window unlocked so that your teenager can come in that way without waking up the dog. It’s not necessarily only going to be your teenager. But then, from a practical point of view, how many people are even going to guess that you left that window unlocked? Or be willing to claim all the way up to use it? Most serious burglars will just break a ground floor window If they want to get in, right?

So… if you are willing to leave yours zigbee network running in insecure mode, then you can follow the Sengled recommendations.

Once it’s been added, then you should be able to use smartlighting with it just as you did, so I agree with @garrett.kranz , you likely just ran into the platform problems today. :disappointed_relieved:

There have been platform problems four or five times in the last six weeks, unfortunately they are not uncommon.

You can sign up for outage notifications on the following page, although not all glitches get reported there and sometimes they don’t get reported for a couple of hours.

https://status.smartthings.com/

1 Like

I have a pair of Sengled Element Touch bulbs that stopped responding to commands and automations yesterday. The events show up fine in my IDE history when I manually turn them on/off, and I can see the current status in the iOS Smartthings app, but they won’t turn on/off or dim from the app. They’ve been working for years without issue. Just curious if it’s related to this smart switch issue.

Your issue sounds like a common issue I’ve had with my multiple Sengled devices. I recommend a work around to “wake up” the devices again.

Put them into a lighting group. Turn them on and off from there a few times. This may kick them into working again. Maybe not immediately, as it sometimes takes an overnight for me, but it seems the lighting group feature blasts out multiple signals at once and often fixes the issue. I really have no idea if the signal sent is any different or if it’s total SmartThings weirdness at play, but it has worked for me many, many times.