secure_my_foscam_local HELP!


(Heath Reed) #1

Is anyone using - secure_my_foscam_local ? I have setup the Foscam device correctly and it is working (other then presets, I’m having a difficult time figuring that out). I think I need some assistance figuring out parts of the code I need to edit before I can actually use it.

If someone could assist me on what I need to fill in first before I use the code that would be awesome!


(Hubert Simon) #2

For the Foscam,take a look at that thread for detailed instructions http://build.smartthings.com/forums/topic/pairing-a-vistacam/


(Heath Reed) #3

I have no idea what I was doing wrong before but I figured it out. One thing to note for the non programmers is that you need " " around the first set of preset variables 1, 2, 3.

One thing I’m still having trouble with is figuring out the presets for the foscam smart device.


(Heath Reed) #4

Never mind. I repasted in the code from the above link and it works fine. I must have screwed something up when i first pasted it in. Thanks for the assist.


(Jim) #5

Thread hijack!

I have a 8918W camera and I am having a bit of trouble. I pasted the code but whenever I push any of the control tiles I see in the IDE log “user not authenticated”

I take the URL from the log and paste it in a web browser and it works perfect.

The only thing different about my setup is I have a reverse proxy setup for my Foscam so my url is https. I’m pretty sure I changed all the http to https in the code.

While I am and IT guy, I’m not much of a programmer.

Any ideas??


(Jeff DeWolfe) #6

Not sure if this will help or not, but I had to change my code to use this url instead:httpGet(“http://${settings.ip}:${settings.port}/snapshot.cgi?user=${settings.username}&pwd=${settings.password}”)

Let me know! I’ll try to help further if needed!


(Morgan) #7

What firmware do you have on the FI8918W?


(Jeff DeWolfe) #8

Currently have 11.37.2.54 installed.


(Jim) #9

I tried changing the URL code as suggested but the same error is showing in the IDE but when I put the URL in a browser is stays “error: illegal params.”

Switching back to the original code, I am still getting “peer not authenticated” but like before when I put the URL in a browser it works.

I am running firmware 11.22.2.51 which is the latest for my Camera, its a bit older and uses a different firmware for whatever reason.


(Jim) #10

Well I am revisiting this tonight - interestingly enough I’m not getting the error I was previously. Now I am receiving

sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target

I assume this is because I don’t have a valid SSL cert? I’m working on getting one now to rule that out…


(Jim) #11

well the one free SSL cert I know of is based in Israel and I don’t want to use that site…

This would be much easier with local network access!! Anyone hear if this is coming?