Foscam: Recommended Model


(Vvarlock) #1

From reading the forums it looks like full support for Foscam devices is still under development. I am curious though, will SmartThings support all foscam models or is there a subset of model types that are being tested against. If I were to get a Foscam now which would have the greatest changes of working with SmartThings once it’s fully supported?


Devices we don't have
(Im Brian) #2

@vvarlock - I made this device type inspired by the work of many (including @megapixel ):

I use it primarily for basic security - and I use this app to arm / disarm it:

If that device controller doesn’t do what you need, let me know and I can probably add it.


(Im Brian) #3

oh, and since I apparently totally ignored your pointed question: I use the foscam fi8910w


(Jeff DeWolfe) #4

Brian- Thanks for that code. I updated the stuff I had from Danny using yours. However, I’m still having issues getting connected to mine. It used to work until I update the firmware and web ui on it in I believe November. Any thoughts? My guess is because of the way the “new” web ui works now. When logging into the camera with Internet Explorer, it no longer pops up with the window asking for credentials, it now takes me to a page asking for them. I believe my model is the fi8918w. Let me know if you have any ideas on how to fix.

Thanks!


(Blake Westerdahl) #5

@chevyman142000

Try changing the URL to “/snapshot.cgi?user=####&pwd=####” (essentially moving the username and password to the end of the URL).

I am still running some of my Foscams through my Vera and this is what I had to do after the most recent firmware update.


(Jeff DeWolfe) #6

httpGet("http://${settings.username}:${settings.password}@${settings.ip}:${settings.port}/snapshot.cgi")

That’s what the original code was. I changed it to this:

httpGet("http://${settings.ip}:${settings.port}/snapshot.cgi?${settings.username}:${settings.password}@")

This is the errors I see in the log when trying to capture a picture.

5:56:46 PM: error null: Name or service not known
5:56:46 PM: debug http://null:null/get_params.cgi?user=null&pwd=null


(Jeff DeWolfe) #7

Just kidding. I went into preferences and set the parameters. It now sort of works…I was able to arm and disarm the alarm, but I get an error when trying to capture a picture. It says unauthorized. I’ll keep digging in the code and see what I can find.


(Jeff DeWolfe) #8

If it helps, this is what I see when trying to capture a photo. All other commands seem to work so far. FYI, I did take the url and login info out. :slight_smile:

 6:04:00 PM: error Unauthorized
  6:04:00 PM: debug Take a photo
  6:03:53 PM: debug http:///decoder_control.cgi?user=&pwd=!&command=31

(Im Brian) #9

Hard for me to test as I only have the one camera - but if you have a pull request (assuming it doesn’t break things for me), I’d love to have it working with more devices. Sorry I couldn’t be more help.


(Blake Westerdahl) #10

@chevyman142000

Try this instead:

httpGet("http://${settings.ip}:${settings.port}/snapshot.cgi?user=${settings.username}&pwd=${settings.password}")

I am able to use this to get an image with my Foscom 8907 with the latest firmware (looks to be same version as the 8918). It’s fixed camera so I can’t test pan and tilt.


(Jeff DeWolfe) #11

You rock! That fixed it!! Thank you thank you!


(Davis Darvish) #12

can someone point me in the direction of basic guides which describe how one can add a custom thing like the camera to their hub?


(llcanada) #13

Do I have to create a new device for each foscam that I have? Also where is the image from the camera store? Can I download it to my hard drive?


(John Palmer) #14

I was wondering the same thing as Davis. Where/how do you add the code for things like the foscam camera? Read posts about adding things but I have no idea how to do it. Thanks!


(Joylove) #15

Subscribing for updates to the questions.


(llcanada) #16

@imbrian when i updated to your 5/2/14 code for Foscam I get the following error?? any idea what or what can I do to fix it.

Thanks


(llcanada) #17

Sorry here the error message

java.lang.RuntimeException: Metadata Error: input() can only be invoked inside a section definition @ line 21


(Im Brian) #18

I’ve just updated it - can you see if this works?


(llcanada) #19

@imbrian Thanks so much works good. Thanks for all you do for us.


(Thinklarge) #20

@imbrian have you been able to get LAN working for your foscam? I’m really curious about this. I’ve been trying to do it for a while now and I haven’t been able to get it done. I followed your steps for configuring the foscam for a public ip.

Just curious if you’ve done anything with that recently. Thanks for all your work man!