Schlage Connect deadbolt w/ alarm stopped working with SmartThings (April 2019)

Having issues with lock connecting to smartthings. I have excluded and reconnected multiple times. Other smart items still working thru hub.

I tried replacing the batteries in the lock to no avail. Had it connected and it worked they my phone a couple times then stopped again.

Tried to factory reset and reconnect everything with no luck.

Any advice?

Which ST hub do you have and which app are you using? Any custom code for locks, if yes, try saving/publish for me again in IDE. Have you tried rebooting the ST hub? How close is the lock to the ST hub when trying to connect it?

It is about 20 feet away and it says it connects. I have tried to restart the hub. Using the smart things app and a 3rd gen hub.

This started just a couple days ago. Had been connected up until that point for the last 3 months with no issue. Below is what I get in the smartthings app.

What specific issue are you facing with the lock?

Open your IDE -> My Devices -> Click on your lock -> What’s the network connectivity state shown (like S0_FAILED or S0_LEGACY etc)?

It showed as connected to smartthings hub. The issue is I can’t control the front door lock from my smartthings app, it just doesn’t do anything.

Can you check this and paste what it says

Also how far is the lock from the nearest hub/repeater?

I hope this is what you need? I just logged in and now it says disconnected. Lock is probably 20-30 feet from hub. First issue I’ve had in the 3 or so months I’ve had it.

No, you’ll need to go into the ide ( and then login and nagivate to:
Login to your IDE -> My Devices -> Click on your lock -> What’s the network connectivity state shown (like S0_FAILED or S0_LEGACY etc)

Is that what you need? I hope this helps, in smartthings it shows as offline. Yesterday after excluding and reinstalling it worked for a minute then stopped again.

That’s the reason the S0_FAILED it has failed a secure network exchange

Looks like a few folks have been seeing this lately with the new firmware. The only solution I can think of is to reset, exclude and re pair the lock.

Also tagging @Kianoosh_Karami who may want to look into your logs.

Yeah reset and excluded it multiple times yesterday trying to get it to work. Worked one time for a minute or two then this again.

One option you would try is bringing it closer to the hub.

I gave up on my Schalge Connect months ago. Good until you upgrade the hub or need to reconnect then its dead no matter what you try. As a lock, they are very good but the connectivity part sucks.

What did you switch to? I am about to dump mine as well. Great working lock but has been nothing but problems for connectivity and battery life.