Schlage Connect Deadbolt, SmartThings Hub v2 - How to Program from SmartThings?

schlage
hubv2

(Margaret) #1

HI, at the end of May, I purchased this deadbolt and connected it to my SmartThings hub v2 using the SmartThings app. I can lock/unlock the deadbolt, and until the latest Android app update, I could see when the deadbolt was locked and unlocked. I’ve NEVER been able to program the deadbolt (add & delete user codes), however.

In this article, it says I can remotely add/delete codes from the SmartThings app. Help in the SmartThings app tells me I can access advanced features of each device by tapping any unused spot on a device card in the Dashboard. Unfortunately when I do that, all I can do is lock or unlock the door. No remote management. See screenshots below:

(The information page doesn’t provide anything other than limited open source data, and the forum won’t let me post more than one image.)

I’ve worked in IT for many years as a network engineer, so I’m frustrated that I can’t figure this out. BTW, I’m using the Android SmartThings app (current version) on a Samsung Galaxy S9 (SM-G960U1) running Android 8.0. I’d really love to be able to manage my lock via SmartThings. Help please?


(jkp) #2

First, use the SmartThings Classic app and not the SmartThings (Samsung Connect) app. With the Classic app, there are three apps you can use.

  1. SmartThings smart looks
    https://support.smartthings.com/hc/en-us/articles/200958090-Smart-Locks-in-SmartThings-Classic
  2. Rboy’s paid app
    [RELEASE] Door lock code/lock user management (create, delete and schedule codes) with automatic lock/unlock, custom user actions and SHM integration
  3. etheyer’s free app
    [RELEASE] Lock Manager

(Margaret) #3

@jkp Thanks, but SmartThings support told me NOT to use the classic app.Before I wrote this post, I did install it, but it won’t allow me to connect to my hub using the welcome code that I used successfully on the new SmartThings app. Advice please?


(jkp) #4

Please contact ST support and work to get logged into the Classic app. At this point, there are no apps for locks that work in the new app.


(Margaret) #5

Will do, thanks. I’m in EDT, so it will be a few hours before the open. It’s unfortunate that the NEW app doesn’t have all the features of the classic app that ST support tells new SmartThings users NOT to use. :frowning:


(jkp) #6

I agree. You can find many threads with others having the same thoughts on ST recommending the new app. :slight_smile: but have to say, they are still working on the new app and it is not finished yet.


(Margaret) #7

Can you at least tell me if I’m going to have to reset my hub, delete/exclude all devices and start over with the classic ST app? I suspect I will…


(jkp) #8

From seeing what others have done, yes, they generally reset their hub and move forward. But you shouldn’t have to do that, they both share the same username/password. You should only need to choose existing hub and login with your Samsung account. I have both installed and using both. But again, contact support before doing anything drastic as resetting your hub.


(Margaret) #9

OK, will do. In the new SmartThings app, I’m using my Samsung account. The classic app seems to want me to use my SmartThings account. I logged in the ST on the web and changed my password. But the classic app will only let me log in with my ST account using the old pwd! Guess I do need Support. Grrr. Thanks! :slight_smile:


(jkp) #10

If you still have a ST account, they should be able to merge it to your Samsung account.


(Margaret) #11

Yes, I have both. Thank you!!!


(Jimmy) #12

Assuming you’ve tried logging in to the classic app as an existing user? You’re supposed to be able to login to both apps with the same credentials, but this seems to be giving people fits. Let us know what support does to fix it so you can login to both.


(Margaret) #13

Yes, I’ve logged in as an existing user, but it requires a welcome code to set up a hub. I’ve used the current welcome code that I used when I originally set up my hub, but it generates an error. I can’t get past the hub set-up, no matter how many times I log out and back in.


(Jimmy) #14

damn. hopefully support can straighten it out.


(Margaret) #15

Me too! There should be a way to log in and bypass hub setup, but there’s not. :frowning:


(Jimmy) #16

there is, because I regularly use both apps, but something must be messed up in the background upon initial setup with the STSC app.


#17

The following thread might be of interest (this is a clickable link)


(Margaret) #18

Thank you!

I just got off the phone with ST Support. The solution is a bit counter-intuitive, but it worked.
.
I was logged into the new SmartThings app with my Samsung account. As an existing user, I was required to use my SmartThings account with ST Classic. All I had to do was to start over and click the new user option. I then got a message that recognized that I was logged in elsewhere with my Samsung account. I told it to go ahead and use my Samsung account, and all my devices appeared!

I can now manage my Schlage Connect lock remotely. Woo hoo! Thanks so much for your help @jkp, @prjct92eh2 and @JDRoberts . Much appreciated! :smiley:


(Jimmy) #19

So if you’re an existing user, choose new user? Got it! :joy:


(Margaret) #20

Yep! All that’s needed is to add a phrase like “or to use a Samsung account,” to save lots of fruitless googling and a call to ST Support. The irony is that I was just about to try the “new user” option while I was on hold. :smile: