Schlage BE369 says it is unlocked

schlage

(Lee Nave) #1

I ran into the usual difficulties pairing the lock but was eventually able to get it working. I can unlock the door from my phone (which in my case requires someone to manually turn the deadbolt, which is fine). But the app says the lock is unlocked, even when it is obviously not.

Anyone here using this lock with ST and actually getting the correct status?


(Jimmy) #2

I have the BE468 and it works great. Sounds like your has a communication issue. What’s the distance between the hub and lock? And name anything in between line of sight.


(Lee Nave) #3

I moved my hub to within a foot of the lock to get through the pairing process and it still doesn’t report the correct state. And like I said, the communication is working because the lock/unlock function works.

Anyone with a BE369 out there?


(jkp) #4

Have you tried running z-wave repair?


(Lee Nave) #5

Yes. (And here are some extra characters so my post meets the minimum 10 required.)


(www.rboyapps.com - Make your home your butler!) #6

Try to kill your ST mobile app and restart it. You can verify from the IDE if the wrong status is being reported or if the ST mobile app is not showing the latest state.


(Lee Nave) #7

The IDE also says it is unlocked.


(Lee Nave) #8

Is there hardware-wise anything I can do to troubleshoot or should I just return the unit and request a new one? I’d feel better about doing that if I could get confirmation from a BE369 owner that theirs works . . .


(Lee Nave) #9

Aha, more information . . . I put the lock in “Lock & Leave” mode, which allows you to lock the door by pushing the Schlage button (without having to enter a code). However, when I push the Schlage button I can also unlock the door. Not good.

Seems this can happen when the cam alignment is not correct during installation. However I went through the installation process four or five times this morning and couldn’t resolve that issue. I’ll contact Schlage next.


(Lee Nave) #10

I disassembled my old (non-Z-wave) Camelot lock to see how the lock knows what status it is in (which it would need to know for Lock & Leave). When the cam is in the unlocked position it pushes a metal contact which depresses a small switch on a rectangular black component. Pretty easy to verify that when that small switch is depressed, the lock thinks it is unlocked (pressing the Schlage button enables the lock mechanism), and when it is not depressed, the lock thinks it is locked (pressing the Schlage button does not enable the lock mechanism).

I then disassembled the BE369 and was able to determine that the same switch is being engaged correctly by the cam but is not detected by the lock. I’m returning the lock for a replacement.


(Lee Nave) #11

Well, geez . . . got the replacement lock today, same model. The Lock & Leave mode works fine. I can enable the locking mechanism via the ST app. Lock permanently reports “Locked”

:angry:


(www.rboyapps.com - Make your home your butler!) #12

You should isolate if it’s a “display” issue or a lock issue or communication issue

  1. Open IDE IDE Live Logging on your computer/phone
  2. Operate the lock physically
  3. Look for the logs in IDE Live Logging
    • If you don’t see any logs then it’s a communication issue, try adding a repeater between your lock and your hub. If you don’t have a repeater, highly recommend adding one to your network as it’s creates a mesh and majority of the issues folks face with locks are related to mesh and lack of repeaters
    • If you see the logs, see what they’re reporting, are they reporting locked or unlocked (it is correct)
      • If it’s correct then the issue is with the ST mobile app, try to kill it and restart it/reboot your phone or contact ST support if it still doesn’t work
      • If it’s not correct, it may be an issue with the firmware, feel free to PM me the logs and I can look at them to tell you if it’s a firmware bug or something else

(Lee Nave) #13

Thanks! Today I got a third lock from Schlage which they manually tested before sending it to me. Same problem! I did the live logging as you suggested and there are no messages at all when the lock is physically turned. When I use the iOS app to engage the locking mechanism, it seems to work correctly:

  1. lock is unlocked
  2. app engages locking mechanism
  3. log reports unlocked status
  4. I turn the lock locked
  5. log reports locked status

Similarly if I use the app to engage the lock but don’t lock it, the log shows unlocked status before and after, i.e., correctly.

However when I use a user code to engage the lock and turn the mechanism (or not), no log messages are generated.

I’m doing this testing physically sitting right next to the hub, so it seems a communications problem is really unlikely, right?

Probably should mention I am using an Nvidia Shield with a Smartthings Link for my hub.


(www.rboyapps.com - Make your home your butler!) #14

This means your lock firmware isn’t reporting that information. Sounds like a bug in the lock firmware. You should report it to Schlage and they may send you a lock with a new firmware that fixes the issue (ST doens’t support Z-Wave firmware updates) or you may check if they can give another model that reports the information like the BE468/469 or the FE599


(Lee Nave) #15

Makes sense. Thanks for the live logging help, that is an invaluable tool.


(Graham) #16

I had a similar problem with my BE369 that I posted recently and got it working (with help from the community). The solution was a) change the name and type (device handler) to “Z-Wave Lock” and b) restart phone (not sure if this was required or not).


(www.rboyapps.com - Make your home your butler!) #17

That’s the default Z-Wave lock handler.

I believe there are different versions of the firmware out there for the BE369. One which reports the user code and the one that does not. In @navels case, either the lock is not reporting the user code event (bad firmware) or the event is getting lost on the mesh, but then trying it multiple time should grab atleast one event.


(Lee Nave) #18

The IDE reports codeVersion = 04.00.05. Is that the lock firmware?


(www.rboyapps.com - Make your home your butler!) #19

No that’s the DTH version. You can find the firmware version by looking at My Devices in the IDE and clicking on the lock name, scroll down, “raw description”

Try to use the code a couple of more times and see if anything shows up up in the logs, just incase the event is getting dropped/lost.


(Lee Nave) #20

I see: firmware version 43.37. Thanks. I’ll try some more tonight.