Schlage 559 door lock

I have 3 Schlage 559 locks. 2 of them I paired with no issues…meaning it only took a few times to pair successfully…the 3rd is giving me fits.

It’s about 8 feet from the hub.

After paring I get a fail notice, but there is a generic zwave device with the only options of on/off.

I’ve deleted a few times and still get the same result.

What should be my next step?

Pair it again, if you get the generic z-wave device again then login to IDE at

Go to Devices from the menu, find that new device, click on the name, choose edit at the bottom of the screen and change type from generic z-wave device to z-wave lock. Ignore the z-wave lock with codes just select z-wave lock.

Go back to the app, refresh the screen and see if everything is working ok. If not, run a z-wave repair.

1 Like

Also see:



I would recommend the following steps:

  1. Reboot the hub (important)
  2. Exclude the lock
  3. Reset the lock to factory defaults
  4. Do NOT use the Generic Z-Wave device option for this lock. In the new ST app, click +, click Devices, click on Scan nearby at the bottom and use that to pair the lock.

Note that there is an issue with the FE599 and the hub firmware which is preventing the lock from sending real time updates to the hub (lock, unlock, code usage notifications, battery etc). We have worked with ST to fix this and it’s the final stages of testing. It should be out in the next week or so and will help restore the notifications for this lock (v0.31.x).

If you’re using the latest version of Enhanced Z-Wave Lock device handler, then you’re good and it’s ready for the new hub firmware. Once the hub firmware is released all you’ll need to do it open the settings page and tap Save and the notifications should start working.

And ofcourse do add a buffering device as @TonyFleisher pointed out, it’ll go a long way to improve your lock stability.

1 Like

So, in the time since I wrote the post I did the following, logged into smartthings and changed the device from generic zwave to zwave lock. I then went to dinner at a great local brew pub (2 beers & 1 sandwich).
Now I see the device showing as a lock. That change was not instant FYI.
Also worth noting: I removed the lock a number of times, I never chose generic zwave device, I always chose schlage zwave lock.
I have absolutely noticed with the other 2 locks that there is no, none, zero real time updating from lock to hub. Yes, even with a repeater.
Sorry, I don’t buy that this hub with 2 locks on it can’t handle that load.
I certainly hope There is an update for the Schlage locks.
The support from Schlage is greatly lacking in this area.

edit: additionally, I thank you folks for the quick responses.

Yes as explained before this is a known issue and will be addressed in the upcoming 0.31.x firmware and with the DTH changes (which have already been incorporated above).

I wasn’t aware/sure I needed to install that device handler.
I’ll give that a shot, also.

The device handler opens up access to many of your FE599 lock features and fixes some bugs in the stock device handler, check out the first post for a detailed list. The real time notifications fix will work once the 0.31.x hub firmware is released.